Skip to content

← Actionable
High, CVSS 8.7

rPGP Panics on Malformed Untrusted Input

CVE-2024-53856GHSA-9rmp-2568-59rv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pgp 0.14.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io pgp

    Affected
    < 0.14.1
    Fixed in
    0.14.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-53856: 0.47% estimated exploitation activity in the next 30 days; percentile 40.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

During a security audit, Radically Open Security discovered several reachable edge cases which allow an attacker to trigger rpgp crashes by providing crafted data. Impact When processing malformed input, rpgp can run into Rust panics which halt the program. This can happen in the following scenarios: Parsing OpenPGP messages from binary or armor format Decrypting OpenPGP messages via decryptwithpassword() Parsing or converting public keys Parsing signed cleartext messages from armor format Using malformed private keys to sign or encrypt Given the affected components, we consider most attack vectors to be reachable by remote attackers during typical use cases of the rpgp library. The attack complexity is low since the malformed messages are generic, short, and require no victim-specific knowledge. The result is a denial-of-service impact via program termination. There is no impact to confidentiality or integrity security properties. Versions and Patches All recent versions are…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9rmp-2568-59rv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-53856

Advisory: rPGP Panics on Malformed Untrusted Input
IDs: CVE-2024-53856, GHSA-9rmp-2568-59rv
Record: https://patchnext.com/advisories/cve-2024-53856 (revision 1, source checked 26 Oct 2026, 15:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pgp 0.14.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io pgp: affected < 0.14.1; fixed in 0.14.1

## Suggested inspection (read-only)
- crates.io pgp: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pgp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9rmp-2568-59rv (GitHub-reviewed advisory GHSA-9rmp-2568-59rv lists affected ranges: crates.io pgp >=0 <0.14.1)

Commands are suggestions: review each one before running it.

Loading voting…