Skip to content

← Actionable
Medium, CVSS 5.1amended

Trix editor subject to XSS vulnerabilities on copy & paste

CVE-2024-53847GHSA-6vx4-v2jw-qwqh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (trix 2.1.9, 1.3.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm trix

    Affected
    >= 2.0.0, < 2.1.9>= 1.0.0, < 1.3.3
    Fixed in
    2.1.9, 1.3.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2024-53847: 0.46% estimated exploitation activity in the next 30 days; percentile 40.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The Trix editor, in versions prior to 2.1.9 and 1.3.3, is vulnerable to XSS + mutation XSS attacks when pasting malicious code. Impact An attacker could trick a user to copy and paste malicious code that would execute arbitrary JavaScript code within the context of the user's session, potentially leading to unauthorized actions being performed or sensitive information being disclosed. Patches Update Recommendation: Users should upgrade to Trix editor version 2.1.9 or later, which uses DOMPurify to sanitize the pasted content. If using Trix 1.x, upgrade to version 1.3.3 or later. Mitigations This is not really a workaround but something that should be considered in addition to upgrading to the patched version. If affected users can disallow browsers that don't support a Content Security Policy, then this would be an effective workaround for this and all XSS vulnerabilities. Set CSP policies such as script-src 'self' to ensure that only scripts hosted on the same origin are executed,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-6vx4-v2jw-qwqh

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-6vx4-v2jw-qwqh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-53847

Advisory: Trix editor subject to XSS vulnerabilities on copy & paste
IDs: CVE-2024-53847, GHSA-6vx4-v2jw-qwqh
Record: https://patchnext.com/advisories/cve-2024-53847 (revision 3, source checked 26 Oct 2026, 12:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: trix 2.1.9, 1.3.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm trix: affected >= 2.0.0, < 2.1.9; >= 1.0.0, < 1.3.3; fixed in 2.1.9, 1.3.3

## Suggested inspection (read-only)
- `npm ls trix --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on trix.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6vx4-v2jw-qwqh (OSV record GHSA-6vx4-v2jw-qwqh lists affected ranges: npm trix >=2.0.0 =1.0.0 <1.3.3 (fixed))
- Verified: https://github.com/advisories/GHSA-6vx4-v2jw-qwqh (GitHub-reviewed advisory GHSA-6vx4-v2jw-qwqh lists affected ranges: npm trix >=2.0.0 =1.0.0 <1.3.3)

Commands are suggestions: review each one before running it.

Loading voting…