Skip to content

← Actionable
Medium, CVSS 6.2amended

@dapperduckling/keycloak-connector-server has Reflected XSS Vulnerability in Authentication Flow URL Handling

CVE-2024-53843GHSA-w5rq-g9r6-vrcg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@dapperduckling/keycloak-connector-server 2.5.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.2 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:U · score source
EPSS
  • CVE-2024-53843: 0.54% estimated exploitation activity in the next 30 days; percentile 45.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A Reflected Cross-Site Scripting (XSS) vulnerability was discovered in the authentication flow of the application. This issue arises due to improper sanitization of the URL parameters, allowing the URL bar's contents to be injected and reflected into the HTML page. An attacker could craft a malicious URL to execute arbitrary JavaScript in the browser of a victim who visits the link. Who is impacted? Any application utilizing this authentication library is vulnerable. Users of the application are at risk if they can be lured into clicking on a crafted malicious link. Patches The vulnerability has been patched in 2.5.5 by ensuring proper sanitization and escaping of user input in the affected URL parameters. Users are strongly encouraged to upgrade to the following versions: Workarounds If upgrading is not immediately possible, users can implement the following workarounds: - Employ a Web Application Firewall (WAF) to block malicious requests containing suspicious URL…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-w5rq-g9r6-vrcg

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-w5rq-g9r6-vrcg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-53843

Advisory: @dapperduckling/keycloak-connector-server has Reflected XSS Vulnerability in Authentication Flow URL Handling
IDs: CVE-2024-53843, GHSA-w5rq-g9r6-vrcg
Record: https://patchnext.com/advisories/cve-2024-53843 (revision 3, source checked 26 Oct 2026, 12:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @dapperduckling/keycloak-connector-server 2.5.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @dapperduckling/keycloak-connector-server: affected < 2.5.5; fixed in 2.5.5

## Suggested inspection (read-only)
- `npm ls @dapperduckling/keycloak-connector-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @dapperduckling/keycloak-connector-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-w5rq-g9r6-vrcg (OSV record GHSA-w5rq-g9r6-vrcg lists affected ranges: npm @dapperduckling/keycloak-connector-server >=0 <2.5.5 (fixed))
- Verified: https://github.com/advisories/GHSA-w5rq-g9r6-vrcg (GitHub-reviewed advisory GHSA-w5rq-g9r6-vrcg lists affected ranges: npm @dapperduckling/keycloak-connector-server >=0 <2.5.5)

Commands are suggestions: review each one before running it.

Loading voting…