BunkerWeb has Open Redirect Vulnerability in Loading Page
CVE-2024-53264GHSA-q9rr-h3hx-m87g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/bunkerity/bunkerweb 1.5.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/bunkerity/bunkerweb
- Affected
- < 1.5.11
- Fixed in
- 1.5.11
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q9rr-h3hx-m87g lists affected ranges: Go github.com/bunkerity/bunkerweb >=0 <1.5.11
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X · score source
- EPSS
- CVE-2024-53264: 0.79% estimated exploitation activity in the next 30 days; percentile 56.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary: A open redirect vulnerability exists in the loading endpoint, allowing attackers to redirect authenticated users to arbitrary external URLs via the "next" parameter. Details: The loading endpoint accepts and uses an unvalidated "next" parameter for redirects: PoC: Visit: /loading?next=https://google.com while authenticated. The page will redirect to google.com. Impact: This vulnerability could be used in phishing attacks by redirecting users from a legitimate application URL to malicious sites.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-q9rr-h3hx-m87g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-53264 Advisory: BunkerWeb has Open Redirect Vulnerability in Loading Page IDs: CVE-2024-53264, GHSA-q9rr-h3hx-m87g Record: https://patchnext.com/advisories/cve-2024-53264 (revision 1, source checked 26 Oct 2026, 15:08 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/bunkerity/bunkerweb 1.5.11. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/bunkerity/bunkerweb: affected < 1.5.11; fixed in 1.5.11 ## Suggested inspection (read-only) - Go github.com/bunkerity/bunkerweb: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/bunkerity/bunkerweb. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-q9rr-h3hx-m87g (GitHub-reviewed advisory GHSA-q9rr-h3hx-m87g lists affected ranges: Go github.com/bunkerity/bunkerweb >=0 <1.5.11) Commands are suggestions: review each one before running it.
Loading voting…