Git LFS permits exfiltration of credentials via crafted HTTP URLs
CVE-2024-53263GHSA-q6r2-x2cc-vrp7
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/git-lfs/git-lfs
- Affected
- >= 0.1.0, <= 3.0.0
- Fixed in
- no fixed version recorded
Go github.com/git-lfs/git-lfs/v3
- Affected
- >= 3.0.0, <= 3.6.0
- Fixed in
- 3.6.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q6r2-x2cc-vrp7 lists affected ranges: Go github.com/git-lfs/git-lfs/v3 >=3.0.0 =0.1.0 <=3.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.5 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-53263: 1.06% estimated exploitation activity in the next 30 days; percentile 64.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact When Git LFS requests credentials from Git for a remote host, it passes portions of the host's URL to the git-credential(1) command without checking for embedded line-ending control characters, and then sends any credentials it receives back from the Git credential helper to the remote host. By inserting URL-encoded control characters such as line feed (LF) or carriage return (CR) characters into the URL, an attacker may be able to retrieve a user's Git credentials. Patches This problem exists in all previous versions and is patched in v3.6.1. All users should upgrade to v3.6.1. Workarounds There are no workarounds known at this time. References https://github.com/git-lfs/git-lfs/security/advisories/GHSA-q6r2-x2cc-vrp7 https://nvd.nist.gov/vuln/detail/CVE-2024-53263 https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2024-53263 https://github.com/git-lfs/git-lfs/releases/tag/v3.6.1 git-lfs/git-lfs@0345b6f816 For more information If you have any questions or comments about this…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-q6r2-x2cc-vrp7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-53263 Advisory: Git LFS permits exfiltration of credentials via crafted HTTP URLs IDs: CVE-2024-53263, GHSA-q6r2-x2cc-vrp7 Record: https://patchnext.com/advisories/cve-2024-53263 (revision 1, source checked 26 Oct 2026, 15:08 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: github.com/git-lfs/git-lfs/v3 3.6.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/git-lfs/git-lfs: affected >= 0.1.0, <= 3.0.0 - Go github.com/git-lfs/git-lfs/v3: affected >= 3.0.0, <= 3.6.0; fixed in 3.6.1 ## Suggested inspection (read-only) - Go github.com/git-lfs/git-lfs: check the installed version with your package manager. - Go github.com/git-lfs/git-lfs/v3: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/git-lfs/git-lfs, github.com/git-lfs/git-lfs/v3. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-q6r2-x2cc-vrp7 (GitHub-reviewed advisory GHSA-q6r2-x2cc-vrp7 lists affected ranges: Go github.com/git-lfs/git-lfs/v3 >=3.0.0 =0.1.0 <=3.0.0) Commands are suggestions: review each one before running it.
Loading voting…