Skip to content

← Actionable
Unratedamended

@sveltejs/kit vulnerable to XSS on dev mode 404 page

CVE-2024-53261GHSA-rjjv-87mx-6x3h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@sveltejs/kit 2.8.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
0.0 · CVSS:3.1/AV:A/AC:L/PR:N/UI:R/S:C/C:N/I:N/A:N
EPSS
  • CVE-2024-53261: 0.35% estimated exploitation activity in the next 30 days; percentile 28.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary "Unsanitized input from the request URL flows into end, where it is used to render an HTML page returned to the user. This may result in a Cross-Site Scripting attack (XSS)." Details Source of potentially tainted data is in packages/kit/src/exports/vite/dev/index.js, line 437. This potentially tainted data is passed through a number of steps (which I could detail if you'd like) all the way down to line 91 in packages/kit/src/exports/vite/utils.js, which performs an operation that Snyk believes an attacker shouldn't be allowed to manipulate. Another source of potentially tainted data (according to Snyk) comes from ‎packages/kit/src/exports/vite/utils.js, line 30, col 30 (i.e., the url property of req). This potentially tainted data is passed through a number of steps (which I could detail if you'd like) all the way down line 91 in packages/kit/src/exports/vite/utils.js, which performs an operation that Snyk believes an attacker shouldn't be allowed to manipulate. PoC Not…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-rjjv-87mx-6x3h

  2. Revision 1 · created ·

    Published from osv record GHSA-rjjv-87mx-6x3h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-53261

Advisory: @sveltejs/kit vulnerable to XSS on dev mode 404 page
IDs: CVE-2024-53261, GHSA-rjjv-87mx-6x3h
Record: https://patchnext.com/advisories/cve-2024-53261 (revision 2, source checked 26 Oct 2026, 12:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated (CVSS 0.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @sveltejs/kit 2.8.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @sveltejs/kit: affected < 2.8.3; fixed in 2.8.3

## Suggested inspection (read-only)
- `npm ls @sveltejs/kit --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @sveltejs/kit.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-rjjv-87mx-6x3h (OSV record GHSA-rjjv-87mx-6x3h lists affected ranges: npm @sveltejs/kit >=0 <2.8.3 (fixed))
- Verified: https://github.com/advisories/GHSA-rjjv-87mx-6x3h (GitHub-reviewed advisory GHSA-rjjv-87mx-6x3h lists affected ranges: npm @sveltejs/kit >=0 <2.8.3)

Commands are suggestions: review each one before running it.

Loading voting…