Sentry improper error handling leaks Application Integration Client Secret
CVE-2024-53253GHSA-v5h2-q2w4-gpcx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sentry 24.11.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI sentry
- Affected
- >= 24.11.0, <= 24.11.0
- Fixed in
- 24.11.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-v5h2-q2w4-gpcx lists affected ranges: PyPI sentry >=24.11.0 <24.11.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v5h2-q2w4-gpcx lists affected ranges: PyPI sentry >=24.11.0 <=24.11.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2024-53253: 0.65% estimated exploitation activity in the next 30 days; percentile 50.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact During routine testing, we identified a scenario where a specific error message generated by our platform could include a plaintext Client ID and Client Secret for an application integration. The Client ID and Client Secret would not be displayed in the UI, but would be returned in the underlying HTTP response to the end user. This could occur under the following conditions: - An app installation made use of a Search UI component with the async flag set to true (default: true), - A user types types into the Search Component which creates a request to the third-party for search or query results, and - That third-party response may then fail validation and Sentry would return the select-requester.invalid-response error code along with a serialized version of a Sentry application containing the integration Client Secret. Should this error be found, it's reasonable to assume the potential exposure of an integration Client Secret. However, an ID and Secret pair alone does not…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-v5h2-q2w4-gpcx
- Revision 1 · created ·
Published from osv record GHSA-v5h2-q2w4-gpcx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-53253 Advisory: Sentry improper error handling leaks Application Integration Client Secret IDs: CVE-2024-53253, GHSA-v5h2-q2w4-gpcx Record: https://patchnext.com/advisories/cve-2024-53253 (revision 2, source checked 26 Oct 2026, 13:44 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sentry 24.11.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI sentry: affected >= 24.11.0, <= 24.11.0; fixed in 24.11.1 ## Suggested inspection (read-only) - `python -m pip show sentry`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sentry. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-v5h2-q2w4-gpcx (OSV record GHSA-v5h2-q2w4-gpcx lists affected ranges: PyPI sentry >=24.11.0 <24.11.1 (fixed)) - Verified: https://github.com/advisories/GHSA-v5h2-q2w4-gpcx (GitHub-reviewed advisory GHSA-v5h2-q2w4-gpcx lists affected ranges: PyPI sentry >=24.11.0 <=24.11.0) Commands are suggestions: review each one before running it.
Loading voting…