PHP Server Monitor vulnerable to Cross-site Scripting
CVE-2024-5312GHSA-rq7f-j68f-mqh3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpservermon/phpservermon 3.3.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist phpservermon/phpservermon
- Affected
- <= 3.2.0
- Fixed in
- 3.3.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rq7f-j68f-mqh3 lists affected ranges: Packagist phpservermon/phpservermon >=0 <=3.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L
- EPSS
- CVE-2024-5312: 0.27% estimated exploitation activity in the next 30 days; percentile 19.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
PHP Server Monitor, version 3.2.0, is vulnerable to an XSS via the /phpservermon-3.2.0/vendor/phpmailer/phpmailer/testscript/index.php page in all visible parameters. An attacker could create a specially crafted URL, send it to a victim and retrieve their session details.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-rq7f-j68f-mqh3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-5312 Advisory: PHP Server Monitor vulnerable to Cross-site Scripting IDs: CVE-2024-5312, GHSA-rq7f-j68f-mqh3 Record: https://patchnext.com/advisories/cve-2024-5312 (revision 1, source checked 26 Oct 2026, 14:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: phpservermon/phpservermon 3.3.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist phpservermon/phpservermon: affected <= 3.2.0; fixed in 3.3.0 ## Suggested inspection (read-only) - Packagist phpservermon/phpservermon: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on phpservermon/phpservermon. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rq7f-j68f-mqh3 (GitHub-reviewed advisory GHSA-rq7f-j68f-mqh3 lists affected ranges: Packagist phpservermon/phpservermon >=0 <=3.2.0) Commands are suggestions: review each one before running it.
Loading voting…