Elasticsearch Vulnerable to Stack Overflow due to a Large Recursion
CVE-2024-52981GHSA-5xm9-x7x4-4j5x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.elasticsearch:elasticsearch 8.15.1, 7.17.24), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.elasticsearch:elasticsearch
- Affected
- >= 7.17.0, <= 7.17.23>= 8.0.0-alpha1, <= 8.15.0
- Fixed in
- 8.15.1, 7.17.24
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5xm9-x7x4-4j5x lists affected ranges: Maven org.elasticsearch:elasticsearch >=7.17.0 =8.0.0-alpha1 <=8.15.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.9 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2024-52981: 0.59% estimated exploitation activity in the next 30 days; percentile 48.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An issue was discovered in Elasticsearch, where a large recursion using the Well-KnownText formatted string with nested GeometryCollection objects could cause a stackoverflow.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5xm9-x7x4-4j5x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-52981 Advisory: Elasticsearch Vulnerable to Stack Overflow due to a Large Recursion IDs: CVE-2024-52981, GHSA-5xm9-x7x4-4j5x Record: https://patchnext.com/advisories/cve-2024-52981 (revision 1, source checked 26 Oct 2026, 16:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.elasticsearch:elasticsearch 8.15.1, 7.17.24. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.elasticsearch:elasticsearch: affected >= 7.17.0, <= 7.17.23; >= 8.0.0-alpha1, <= 8.15.0; fixed in 8.15.1, 7.17.24 ## Suggested inspection (read-only) - Maven org.elasticsearch:elasticsearch: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.elasticsearch:elasticsearch. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5xm9-x7x4-4j5x (GitHub-reviewed advisory GHSA-5xm9-x7x4-4j5x lists affected ranges: Maven org.elasticsearch:elasticsearch >=7.17.0 =8.0.0-alpha1 <=8.15.0) Commands are suggestions: review each one before running it.
Loading voting…