LF Edge eKuiper allows Stored XSS in Rules Functionality
CVE-2024-52812GHSA-6hrw-x7pr-4mp8
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/lf-edge/ekuiper/v2
- Affected
- < 2.0.8
- Fixed in
- 2.0.8
Go github.com/lf-edge/ekuiper
- Affected
- <= 1.14.7
- Fixed in
- no fixed version recorded
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6hrw-x7pr-4mp8 lists affected ranges: Go github.com/lf-edge/ekuiper/v2 >=0 =0 <=1.14.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- EPSS
- CVE-2024-52812: 0.35% estimated exploitation activity in the next 30 days; percentile 28.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Stored Cross-Site Scripting (XSS) vulnerability allows attackers to inject malicious scripts into web applications, which can then be executed in the context of other users' browsers. This can lead to unauthorized access to sensitive information, session hijacking, and spreading of malware, impacting user data privacy and application integrity. Details A user with rights to modificate the service (e.g. kuiperUser role) can inject XSS Payload into Rule id parameter. Then, after any user with access to this service (e.g. admin) will try make any modifications with the rule (update, run, stop, delete), a payload will act in victim's browser. The issue appears as the notification to user is made in an insafe way: https://github.com/lf-edge/ekuiper/blob/dbce32d5a195cf1de949b3a6a4e29f0df0f3330d/internal/server/rest.go#L681 https://github.com/lf-edge/ekuiper/blob/dbce32d5a195cf1de949b3a6a4e29f0df0f3330d/internal/server/rest.go#L716…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6hrw-x7pr-4mp8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-52812 Advisory: LF Edge eKuiper allows Stored XSS in Rules Functionality IDs: CVE-2024-52812, GHSA-6hrw-x7pr-4mp8 Record: https://patchnext.com/advisories/cve-2024-52812 (revision 1, source checked 26 Oct 2026, 15:09 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: github.com/lf-edge/ekuiper/v2 2.0.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/lf-edge/ekuiper/v2: affected < 2.0.8; fixed in 2.0.8 - Go github.com/lf-edge/ekuiper: affected <= 1.14.7 ## Suggested inspection (read-only) - Go github.com/lf-edge/ekuiper/v2: check the installed version with your package manager. - Go github.com/lf-edge/ekuiper: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/lf-edge/ekuiper/v2, github.com/lf-edge/ekuiper. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6hrw-x7pr-4mp8 (GitHub-reviewed advisory GHSA-6hrw-x7pr-4mp8 lists affected ranges: Go github.com/lf-edge/ekuiper/v2 >=0 =0 <=1.14.7) Commands are suggestions: review each one before running it.
Loading voting…