Skip to content

← Actionable
Medium, CVSS 6.9amended

@intlify/shared Prototype Pollution vulnerability

CVE-2024-52810GHSA-hjwq-mjwj-4x6c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@intlify/shared 10.0.5, 9.14.2; @intlify/vue-i18n-core 10.0.5, 9.14.2; vue-i18n 10.0.5, 9.14.2; petite-vue-i18n 10.0.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm @intlify/shared

    Affected
    >= 9.7.0, < 9.14.2>= 10.0.0, < 10.0.5
    Fixed in
    10.0.5, 9.14.2
  • npm @intlify/vue-i18n-core

    Affected
    >= 9.7.0, < 9.14.2>= 10.0.0, < 10.0.5
    Fixed in
    10.0.5, 9.14.2
  • npm vue-i18n

    Affected
    >= 9.7.0, < 9.14.2>= 10.0.0, < 10.0.5
    Fixed in
    10.0.5, 9.14.2
  • npm petite-vue-i18n

    Affected
    >= 10.0.0, < 10.0.5
    Fixed in
    10.0.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X · score source
EPSS
  • CVE-2024-52810: 0.77% estimated exploitation activity in the next 30 days; percentile 55.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Vulnerability type: Prototype Pollution Affected Package: Product: @intlify/shared Version: 10.0.4 Vulnerability Location(s): nodemodules/@intlify/shared/dist/shared.cjs:232:26 Description: The latest version of @intlify/shared (10.0.4) is vulnerable to Prototype Pollution through the entry function(s) lib.deepCopy. An attacker can supply a payload with Object.prototype setter to introduce or modify properties within the global prototype chain, causing denial of service (DoS) the minimum consequence. Moreover, the consequences of this vulnerability can escalate to other injection-based attacks, depending on how the library integrates within the application. For instance, if the polluted property propagates to sensitive Node.js APIs (e.g., exec, eval), it could enable an attacker to execute arbitrary commands within the application's context. PoC: References Prototype Pollution Leading to Remote Code Execution - An example of how prototype pollution can lead to command code injection.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-hjwq-mjwj-4x6c

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-hjwq-mjwj-4x6c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-52810

Advisory: @intlify/shared Prototype Pollution vulnerability
IDs: CVE-2024-52810, GHSA-hjwq-mjwj-4x6c
Record: https://patchnext.com/advisories/cve-2024-52810 (revision 3, source checked 26 Oct 2026, 12:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @intlify/shared 10.0.5, 9.14.2; @intlify/vue-i18n-core 10.0.5, 9.14.2; vue-i18n 10.0.5, 9.14.2; petite-vue-i18n 10.0.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @intlify/shared: affected >= 9.7.0, < 9.14.2; >= 10.0.0, < 10.0.5; fixed in 10.0.5, 9.14.2
- npm @intlify/vue-i18n-core: affected >= 9.7.0, < 9.14.2; >= 10.0.0, < 10.0.5; fixed in 10.0.5, 9.14.2
- npm vue-i18n: affected >= 9.7.0, < 9.14.2; >= 10.0.0, < 10.0.5; fixed in 10.0.5, 9.14.2
- npm petite-vue-i18n: affected >= 10.0.0, < 10.0.5; fixed in 10.0.5

## Suggested inspection (read-only)
- `npm ls @intlify/shared --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @intlify/vue-i18n-core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls vue-i18n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls petite-vue-i18n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @intlify/shared, @intlify/vue-i18n-core, vue-i18n, petite-vue-i18n.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hjwq-mjwj-4x6c (OSV record GHSA-hjwq-mjwj-4x6c lists affected ranges: npm @intlify/shared >=9.7.0 =10.0.0 =9.7.0 =10.0.0 =9.7.0 =10.0.0 =10.0.0 <10.0.5 (fixed))
- Verified: https://github.com/advisories/GHSA-hjwq-mjwj-4x6c (GitHub-reviewed advisory GHSA-hjwq-mjwj-4x6c lists affected ranges: npm @intlify/shared >=9.7.0 =10.0.0 =9.7.0 =10.0.0 =9.7.0 =10.0.0 =10.0.0 <10.0.5)

Commands are suggestions: review each one before running it.

Loading voting…