Skip to content

← Actionable
Medium, CVSS 5.3amended

vue-i18n has cross-site scripting vulnerability with prototype pollution

CVE-2024-52809GHSA-9r9m-ffp6-9x4v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@intlify/vue-i18n-core 10.0.5, 9.14.2; vue-i18n 10.0.5, 9.14.2; petite-vue-i18n 10.0.5; @intlify/core-base 10.0.5, 9.14.2; @intlify/core 10.0.5, 9.14.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm @intlify/vue-i18n-core

    Affected
    >= 9.3.0, < 9.14.2>= 10.0.0, < 10.0.5
    Fixed in
    10.0.5, 9.14.2
  • npm vue-i18n

    Affected
    >= 9.3.0, < 9.14.2>= 10.0.0, < 10.0.5
    Fixed in
    10.0.5, 9.14.2
  • npm petite-vue-i18n

    Affected
    >= 10.0.0, < 10.0.5
    Fixed in
    10.0.5
  • npm @intlify/core-base

    Affected
    >= 9.3.0, < 9.14.2>= 10.0.0, < 10.0.5
    Fixed in
    10.0.5, 9.14.2
  • npm @intlify/core

    Affected
    >= 9.3.0, < 9.14.2>= 10.0.0, < 10.0.5
    Fixed in
    10.0.5, 9.14.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X · score source
EPSS
  • CVE-2024-52809: 0.67% estimated exploitation activity in the next 30 days; percentile 52.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Vulnerability type XSS Description vue-i18n can be passed locale messages to createI18n or useI18n. we can then translate them using t and $t. vue-i18n has its own syntax for local messages, and uses a message compiler to generate AST. In order to maximize the performance of the translation function, vue-i18n uses bundler plugins such as @intlify/unplugin-vue-i18n and bulder to convert the AST in advance when building the application. By using that AST as the locale message, it is no longer necessary to compile, and it is possible to translate using the AST. The AST generated by the message compiler has special properties for each node in the AST tree to maximize performance. In the PoC example below, it is a static property, but that is just one of the optimizations. About details of special properties, see https://github.com/intlify/vue-i18n/blob/master/packages/message-compiler/src/nodes.ts In general, the locale messages of vue-i18n are optimized during production builds using…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-9r9m-ffp6-9x4v

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-9r9m-ffp6-9x4v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-52809

Advisory: vue-i18n has cross-site scripting vulnerability with prototype pollution
IDs: CVE-2024-52809, GHSA-9r9m-ffp6-9x4v
Record: https://patchnext.com/advisories/cve-2024-52809 (revision 3, source checked 26 Oct 2026, 12:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @intlify/vue-i18n-core 10.0.5, 9.14.2; vue-i18n 10.0.5, 9.14.2; petite-vue-i18n 10.0.5; @intlify/core-base 10.0.5, 9.14.2; @intlify/core 10.0.5, 9.14.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @intlify/vue-i18n-core: affected >= 9.3.0, < 9.14.2; >= 10.0.0, < 10.0.5; fixed in 10.0.5, 9.14.2
- npm vue-i18n: affected >= 9.3.0, < 9.14.2; >= 10.0.0, < 10.0.5; fixed in 10.0.5, 9.14.2
- npm petite-vue-i18n: affected >= 10.0.0, < 10.0.5; fixed in 10.0.5
- npm @intlify/core-base: affected >= 9.3.0, < 9.14.2; >= 10.0.0, < 10.0.5; fixed in 10.0.5, 9.14.2
- npm @intlify/core: affected >= 9.3.0, < 9.14.2; >= 10.0.0, < 10.0.5; fixed in 10.0.5, 9.14.2

## Suggested inspection (read-only)
- `npm ls @intlify/vue-i18n-core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls vue-i18n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls petite-vue-i18n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @intlify/core-base --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @intlify/core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @intlify/vue-i18n-core, vue-i18n, petite-vue-i18n, @intlify/core-base, @intlify/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9r9m-ffp6-9x4v (OSV record GHSA-9r9m-ffp6-9x4v lists affected ranges: npm @intlify/core-base >=9.3.0 =10.0.0 =9.3.0 =10.0.0 =9.3.0 =10.0.0 =9.3.0 =10.0.0 =10.0.0 <10.0.5 (fixed))
- Verified: https://github.com/advisories/GHSA-9r9m-ffp6-9x4v (GitHub-reviewed advisory GHSA-9r9m-ffp6-9x4v lists affected ranges: npm @intlify/core-base >=9.3.0 =10.0.0 =9.3.0 =10.0.0 =9.3.0 =10.0.0 =9.3.0 =10.0.0 =10.0.0 <10.0.5)

Commands are suggestions: review each one before running it.

Loading voting…