Skip to content

← Actionable
Medium, CVSS 6.9

SimpleSAMLphp SAML2 has an XXE in parsing SAML messages

CVE-2024-52806GHSA-pxm4-r5ph-q2m2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (simplesamlphp/saml2-legacy 4.6.14; simplesamlphp/saml2 4.6.14), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:L · score source
EPSS
  • CVE-2024-52806: 0.43% estimated exploitation activity in the next 30 days; percentile 37.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary When loading an (untrusted) XML document, for example the SAMLResponse, it's possible to induce an XXE. $options is defined as: https://github.com/simplesamlphp/saml2/blob/717c0adc4877ebd58428637e5626345e59fa0109/src/SAML2/DOMDocumentFactory.php#L41 including the DTDLoad option, which allows an attacker to read file contents from local file system OR internal network. While there is the NONET option, an attacker can simply bypass if by using PHP filters: php://filter/convert.base64-encode/resource=http://URL OR FILE From there an attacker can induce network connections and steal the targeted file OOB (haven't fully tested this). RCE may be possible with the php://expect or php://phar wrappers, but this hasn't been tested. Note: The mitigation here: https://github.com/simplesamlphp/saml2/blob/717c0adc4877ebd58428637e5626345e59fa0109/src/SAML2/DOMDocumentFactory.php#L63-L69 Comes too late, as the XML has already been loaded into a document. Mitigation: Remove the LIBXMLDTDLOAD…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-pxm4-r5ph-q2m2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-52806

Advisory: SimpleSAMLphp SAML2 has an XXE in parsing SAML messages
IDs: CVE-2024-52806, GHSA-pxm4-r5ph-q2m2
Record: https://patchnext.com/advisories/cve-2024-52806 (revision 1, source checked 26 Oct 2026, 14:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: simplesamlphp/saml2-legacy 4.6.14; simplesamlphp/saml2 4.6.14. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist simplesamlphp/saml2-legacy: affected < 4.6.14; fixed in 4.6.14
- Packagist simplesamlphp/saml2: affected < 4.6.14; fixed in 4.6.14

## Suggested inspection (read-only)
- Packagist simplesamlphp/saml2-legacy: check the installed version with your package manager.
- Packagist simplesamlphp/saml2: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on simplesamlphp/saml2-legacy, simplesamlphp/saml2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-pxm4-r5ph-q2m2 (GitHub-reviewed advisory GHSA-pxm4-r5ph-q2m2 lists affected ranges: Packagist simplesamlphp/saml2 >=0 =0 <4.6.14)

Commands are suggestions: review each one before running it.

Loading voting…