Skip to content

← Actionable
High, CVSS 8.2amended

Synapse allows unsupported content types to lead to memory exhaustion

CVE-2024-52805GHSA-rfq8-j7rh-8hf2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (matrix-synapse 1.120.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X · score source
EPSS
  • CVE-2024-52805: 0.74% estimated exploitation activity in the next 30 days; percentile 54.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact In Synapse before 1.120.1, multipart/form-data requests can in certain configurations transiently increase memory consumption beyond expected levels while processing the request, which can be used to amplify denial of service attacks. Patches Synapse 1.120.1 resolves the issue by denying requests with unsupported multipart/form-data content type. Workarounds Limiting request sizes or blocking the multipart/form-data content type before the requests reach Synapse, for example in a reverse proxy, alleviates the issue. Another approach that mitigates the attack is to use a low maxuploadsize in Synapse. References - https://github.com/twisted/twisted/issues/4688#issuecomment-1167705518 - https://github.com/twisted/twisted/issues/4688#issuecomment-2385711609 For more information If you have any questions or comments about this advisory, please email us at security at element.io.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-rfq8-j7rh-8hf2

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-rfq8-j7rh-8hf2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-52805

Advisory: Synapse allows unsupported content types to lead to memory exhaustion
IDs: CVE-2024-52805, GHSA-rfq8-j7rh-8hf2
Record: https://patchnext.com/advisories/cve-2024-52805 (revision 3, source checked 26 Oct 2026, 13:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: matrix-synapse 1.120.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI matrix-synapse: affected < 1.120.1; fixed in 1.120.1

## Suggested inspection (read-only)
- `python -m pip show matrix-synapse`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on matrix-synapse.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-rfq8-j7rh-8hf2 (OSV record GHSA-rfq8-j7rh-8hf2 lists affected ranges: PyPI matrix-synapse >=0 <1.120.1 (fixed))
- Verified: https://github.com/advisories/GHSA-rfq8-j7rh-8hf2 (GitHub-reviewed advisory GHSA-rfq8-j7rh-8hf2 lists affected ranges: PyPI matrix-synapse >=0 <1.120.1)

Commands are suggestions: review each one before running it.

Loading voting…