Skip to content

← Actionable
High, CVSS 7.5amended

LLama Factory Remote OS Command Injection Vulnerability

CVE-2024-52803GHSA-hj3w-wrh4-44vp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (llamafactory 0.9.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2024-52803: 2.32% estimated exploitation activity in the next 30 days; percentile 83.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A critical remote OS command injection vulnerability has been identified in the Llama Factory training process. This vulnerability arises from improper handling of user input, allowing malicious actors to execute arbitrary OS commands on the host system. The issue is caused by insecure usage of the Popen function with shell=True, coupled with unsanitized user input. Immediate remediation is required to mitigate the risk. Affected Version Llama Factory versions <=0.9.0 are affected by this vulnerability. Impact Exploitation of this vulnerability allows attackers to: 1. Execute arbitrary OS commands on the server. 2. Potentially compromise sensitive data or escalate privileges. 3. Deploy malware or create persistent backdoors in the system. This significantly increases the risk of data breaches and operational disruption. Root Cause The vulnerability originates from the training process where the outputdir value, obtained from the user input, is injected into the popen function…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-hj3w-wrh4-44vp

  2. Revision 1 · created ·

    Published from osv record GHSA-hj3w-wrh4-44vp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-52803

Advisory: LLama Factory Remote OS Command Injection Vulnerability
IDs: CVE-2024-52803, GHSA-hj3w-wrh4-44vp
Record: https://patchnext.com/advisories/cve-2024-52803 (revision 2, source checked 26 Oct 2026, 13:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: llamafactory 0.9.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI llamafactory: affected <= 0.9.0; fixed in 0.9.1

## Suggested inspection (read-only)
- `python -m pip show llamafactory`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on llamafactory.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hj3w-wrh4-44vp (OSV record GHSA-hj3w-wrh4-44vp lists affected ranges: PyPI llamafactory >=0 <0.9.1 (fixed))
- Verified: https://github.com/advisories/GHSA-hj3w-wrh4-44vp (GitHub-reviewed advisory GHSA-hj3w-wrh4-44vp lists affected ranges: PyPI llamafactory >=0 <=0.9.0)

Commands are suggestions: review each one before running it.

Loading voting…