Skip to content

← Actionable
Medium, CVSS 6.5

Searching Opencast may cause a denial of service

CVE-2024-52797GHSA-jh6x-7xfg-9cq2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.opencastproject:opencast-elasticsearch-impl 16.7, 14.3, 13.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2024-52797: 0.92% estimated exploitation activity in the next 30 days; percentile 60.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact First noticed in Opencast 13 and 14, Opencast's Elasticsearch integration may generate syntactically invalid Elasticsearch queries in relation to previously acceptable search queries. From Opencast version 11.4 and newer, Elasticsearch queries are retried a configurable number of times in the case of error to handle temporary losses of connection to Elasticsearch. These invalid queries would fail, causing the retry mechanism to begin requerying with the same syntactically invalid query immediately, in an infinite loop. This causes a massive increase in log size which can in some cases cause a denial of service due to disk exhaustion. Patches Opencast 13.10 and Opencast 14.3 contain patches (https://github.com/opencast/opencast/pull/5150, and https://github.com/opencast/opencast/pull/5033) which address the base issue, with Opencast 16.7 containing changes which harmonize the search behaviour between the admin UI and external API. Users are strongly recommended to upgrade as…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jh6x-7xfg-9cq2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-52797

Advisory: Searching Opencast may cause a denial of service
IDs: CVE-2024-52797, GHSA-jh6x-7xfg-9cq2
Record: https://patchnext.com/advisories/cve-2024-52797 (revision 1, source checked 26 Oct 2026, 16:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.opencastproject:opencast-elasticsearch-impl 16.7, 14.3, 13.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.opencastproject:opencast-elasticsearch-impl: affected >= 14.0, < 14.3; >= 15.0, <= 16.6; >= 11.4, < 13.10; fixed in 16.7, 13.10, 14.3

## Suggested inspection (read-only)
- Maven org.opencastproject:opencast-elasticsearch-impl: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.opencastproject:opencast-elasticsearch-impl.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jh6x-7xfg-9cq2 (GitHub-reviewed advisory GHSA-jh6x-7xfg-9cq2 lists affected ranges: Maven org.opencastproject:opencast-elasticsearch-impl >=14.0 =15.0 =11.4 <13.10)

Commands are suggestions: review each one before running it.

Loading voting…