Skip to content

← Actionable
Medium, CVSS 4.9amended

Strapi allows Server-Side Request Forgery in Webhook function

CVE-2024-52588GHSA-v8wj-f5c7-pvxf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@strapi/admin 4.25.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.9 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2024-52588: 0.59% estimated exploitation activity in the next 30 days; percentile 48.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description In Strapi latest version, at function Settings - Webhooks, the application allows us to input a URL in order to create a Webook connection. However, we can input into this field the local domains such as localhost, 127.0.0.1, 0.0.0.0,.... in order to make the Application fetching into the internal itself, which causes the vulnerability Server - Side Request Forgery (SSRF). Payloads - http://127.0.0.1:80 - The Port is not open - http://127.0.0.1:1337 - The Port which Strapi is running on Steps to Reproduce - First of all, let's input the URL http://127.0.0.1:80 into the URL field, and click "Save". - Next, use the "Trigger" function and use Burp Suite to capture the request / response - The server return request to http://127.0.0.1/ failed, reason: connect ECONNREFUSED 127.0.0.1:80, BECAUSE the Port 80 is not open, since we are running Strapi on Port 1337, let's change the URL we input above into http://127.0.0.1:1337 - Continue to click the "Trigger" function, use Burp to…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-v8wj-f5c7-pvxf

  2. Revision 1 · created ·

    Published from osv record GHSA-v8wj-f5c7-pvxf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-52588

Advisory: Strapi allows Server-Side Request Forgery in Webhook function
IDs: CVE-2024-52588, GHSA-v8wj-f5c7-pvxf
Record: https://patchnext.com/advisories/cve-2024-52588 (revision 2, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @strapi/admin 4.25.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @strapi/admin: affected < 4.25.2; fixed in 4.25.2

## Suggested inspection (read-only)
- `npm ls @strapi/admin --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @strapi/admin.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-v8wj-f5c7-pvxf (OSV record GHSA-v8wj-f5c7-pvxf lists affected ranges: npm @strapi/admin >=0 <4.25.2 (fixed))
- Verified: https://github.com/advisories/GHSA-v8wj-f5c7-pvxf (GitHub-reviewed advisory GHSA-v8wj-f5c7-pvxf lists affected ranges: npm @strapi/admin >=0 <4.25.2)

Commands are suggestions: review each one before running it.

Loading voting…