Cilium's Layer 7 policy enforcement may not occur in policies with wildcarded port ranges
CVE-2024-52529GHSA-xg58-75qf-9r67
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/cilium/cilium 1.16.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 1.16.0, < 1.16.4
- Fixed in
- 1.16.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xg58-75qf-9r67 lists affected ranges: Go github.com/cilium/cilium >=1.16.0 <1.16.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N · score source
- EPSS
- CVE-2024-52529: 0.52% estimated exploitation activity in the next 30 days; percentile 44.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact For users with the following configuration: An allow policy that selects a Layer 3 identity and a port range AND A Layer 7 allow policy that selects a specific port within the first policy's range then Layer 7 enforcement would not occur for the traffic selected by the Layer 7 policy. This issue only affects users who use Cilium's port range functionality, which was introduced in Cilium v1.16. For reference, an example of a pair of policies that would trigger this issue is: and In the above example, requests would be permitted to all HTTP paths on matching endpoints, rather than just GET requests to the /public path as intended by the layer-4-and-7 policy. In patched versions of Cilium, the layer-4-and-7 rule would take precedence over the layer-3-and-4 rule. Patches This issue is patched in https://github.com/cilium/cilium/pull/35150. This issue affects Cilium v1.16 between v1.16.0 and v1.16.3 inclusive. This issue is patched in Cilium v1.16.4. Workarounds Users with network…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-xg58-75qf-9r67
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-52529 Advisory: Cilium's Layer 7 policy enforcement may not occur in policies with wildcarded port ranges IDs: CVE-2024-52529, GHSA-xg58-75qf-9r67 Record: https://patchnext.com/advisories/cve-2024-52529 (revision 1, source checked 26 Oct 2026, 15:08 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/cilium/cilium 1.16.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/cilium/cilium: affected >= 1.16.0, < 1.16.4; fixed in 1.16.4 ## Suggested inspection (read-only) - Go github.com/cilium/cilium: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/cilium/cilium. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xg58-75qf-9r67 (GitHub-reviewed advisory GHSA-xg58-75qf-9r67 lists affected ranges: Go github.com/cilium/cilium >=1.16.0 <1.16.4) Commands are suggestions: review each one before running it.
Loading voting…