ReDoS in giskard's transformation.py (GHSL-2024-324)
CVE-2024-52524GHSA-pjwm-cr36-mwv3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (giskard 2.15.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI giskard
- Affected
- <= 2.15.4
- Fixed in
- 2.15.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pjwm-cr36-mwv3 lists affected ranges: PyPI giskard >=0 <2.15.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pjwm-cr36-mwv3 lists affected ranges: PyPI giskard >=0 <=2.15.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:Clear · score source
- EPSS
- CVE-2024-52524: 0.82% estimated exploitation activity in the next 30 days; percentile 57.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
ReDoS in Giskard text perturbation detector A Remote Code Execution (ReDoS) vulnerability was discovered in Giskard component by the GitHub Security Lab team. When processing datasets with specific text patterns with Giskard detectors, this vulnerability could trigger exponential regex evaluation times, potentially leading to denial of service. Details The vulnerability affects Giskard's punctuation removal transformation used in the text perturbation detection. A regex used to detect URLs and links was vulnerable to catastrophic backtracking that could be triggered by specific patterns in the text. Affected version Giskard versions prior to 2.15.5 are affected. Users should upgrade to version 2.15.5 or later, which includes a fix for this vulnerability. Impact This vulnerability can cause extended computation times or crashes in Giskard when processing text containing certain patterns. Credit This issue was discovered and reported by GHSL team member @kevinbackhouse (Kevin Backhouse).
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-pjwm-cr36-mwv3
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-pjwm-cr36-mwv3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-52524 Advisory: ReDoS in giskard's transformation.py (GHSL-2024-324) IDs: CVE-2024-52524, GHSA-pjwm-cr36-mwv3 Record: https://patchnext.com/advisories/cve-2024-52524 (revision 3, source checked 26 Oct 2026, 13:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: giskard 2.15.5. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI giskard: affected <= 2.15.4; fixed in 2.15.5 ## Suggested inspection (read-only) - `python -m pip show giskard`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on giskard. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-pjwm-cr36-mwv3 (OSV record GHSA-pjwm-cr36-mwv3 lists affected ranges: PyPI giskard >=0 <2.15.5 (fixed)) - Verified: https://github.com/advisories/GHSA-pjwm-cr36-mwv3 (GitHub-reviewed advisory GHSA-pjwm-cr36-mwv3 lists affected ranges: PyPI giskard >=0 <=2.15.4) Commands are suggestions: review each one before running it.
Loading voting…