Apache Tomcat Request and/or response mix-up
CVE-2024-52317GHSA-qvf5-hvjx-wm27
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.tomcat:tomcat-coyote 11.0.0, 10.1.31, 9.0.96; org.apache.tomcat.embed:tomcat-embed-core 11.0.0, 10.1.31, 9.0.96), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.tomcat:tomcat-coyote
- Affected
- >= 9.0.92, < 9.0.96>= 10.1.27, < 10.1.31>= 11.0.0-M23, < 11.0.0
- Fixed in
- 9.0.96, 10.1.31, 11.0.0
Maven org.apache.tomcat.embed:tomcat-embed-core
- Affected
- >= 9.0.92, < 9.0.96>= 10.1.27, < 10.1.31>= 11.0.0-M23, < 11.0.0
- Fixed in
- 9.0.96, 10.1.31, 11.0.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qvf5-hvjx-wm27 lists affected ranges: Maven org.apache.tomcat.embed:tomcat-embed-core >=9.0.92 =10.1.27 =11.0.0-M23 =9.0.92 =10.1.27 =11.0.0-M23 <11.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- EPSS
- CVE-2024-52317: 2.10% estimated exploitation activity in the next 30 days; percentile 81.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Incorrect object re-cycling and re-use vulnerability in Apache Tomcat. Incorrect recycling of the request and response used by HTTP/2 requests could lead to request and/or response mix-up between users. This issue affects Apache Tomcat: from 11.0.0-M23 through 11.0.0-M26, from 10.1.27 through 10.1.30, from 9.0.92 through 9.0.95. Users are recommended to upgrade to version 11.0.0, 10.1.31 or 9.0.96, which fixes the issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-qvf5-hvjx-wm27
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-52317 Advisory: Apache Tomcat Request and/or response mix-up IDs: CVE-2024-52317, GHSA-qvf5-hvjx-wm27 Record: https://patchnext.com/advisories/cve-2024-52317 (revision 1, source checked 26 Oct 2026, 16:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.tomcat:tomcat-coyote 11.0.0, 10.1.31, 9.0.96; org.apache.tomcat.embed:tomcat-embed-core 11.0.0, 10.1.31, 9.0.96. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.tomcat:tomcat-coyote: affected >= 9.0.92, < 9.0.96; >= 10.1.27, < 10.1.31; >= 11.0.0-M23, < 11.0.0; fixed in 9.0.96, 10.1.31, 11.0.0 - Maven org.apache.tomcat.embed:tomcat-embed-core: affected >= 9.0.92, < 9.0.96; >= 10.1.27, < 10.1.31; >= 11.0.0-M23, < 11.0.0; fixed in 9.0.96, 10.1.31, 11.0.0 ## Suggested inspection (read-only) - Maven org.apache.tomcat:tomcat-coyote: check the installed version with your package manager. - Maven org.apache.tomcat.embed:tomcat-embed-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.tomcat:tomcat-coyote, org.apache.tomcat.embed:tomcat-embed-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qvf5-hvjx-wm27 (GitHub-reviewed advisory GHSA-qvf5-hvjx-wm27 lists affected ranges: Maven org.apache.tomcat.embed:tomcat-embed-core >=9.0.92 =10.1.27 =11.0.0-M23 =9.0.92 =10.1.27 =11.0.0-M23 <11.0.0) Commands are suggestions: review each one before running it.
Loading voting…