Connecting to a malicious Codespaces via GH CLI could allow command execution on the user's computer
CVE-2024-52308GHSA-p2h2-3vg9-4p87
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/cli/cli/v2 2.62.0; github.com/cli/cli 2.62.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- <= 2.61.0
- Fixed in
- 2.62.0
- Affected
- < 2.62.0
- Fixed in
- 2.62.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p2h2-3vg9-4p87 lists affected ranges: Go github.com/cli/cli/v2 >=0 =0 <2.62.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.0 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H
- EPSS
- CVE-2024-52308: 0.91% estimated exploitation activity in the next 30 days; percentile 59.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A security vulnerability has been identified in GitHub CLI that could allow remote code execution (RCE) when users connect to a malicious Codespace SSH server and use the gh codespace ssh or gh codespace logs commands. Details The vulnerability stems from the way GitHub CLI handles SSH connection details when executing commands. When developers connect to remote Codespaces, they typically use a SSH server running within a devcontainer, often provided through the default devcontainer image. GitHub CLI retrieves SSH connection details, such as remote username, which is used in executing ssh commands for gh codespace ssh or gh codespace logs commands. This exploit occurs when a malicious third-party devcontainer contains a modified SSH server that injects ssh arguments within the SSH connection details. gh codespace ssh and gh codespace logs commands could execute arbitrary code on the user's workstation if the remote username contains something like -oProxyCommand="echo hacked"…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-p2h2-3vg9-4p87
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-52308 Advisory: Connecting to a malicious Codespaces via GH CLI could allow command execution on the user's computer IDs: CVE-2024-52308, GHSA-p2h2-3vg9-4p87 Record: https://patchnext.com/advisories/cve-2024-52308 (revision 1, source checked 26 Oct 2026, 15:08 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/cli/cli/v2 2.62.0; github.com/cli/cli 2.62.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/cli/cli/v2: affected <= 2.61.0; fixed in 2.62.0 - Go github.com/cli/cli: affected < 2.62.0; fixed in 2.62.0 ## Suggested inspection (read-only) - Go github.com/cli/cli/v2: check the installed version with your package manager. - Go github.com/cli/cli: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/cli/cli/v2, github.com/cli/cli. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-p2h2-3vg9-4p87 (GitHub-reviewed advisory GHSA-p2h2-3vg9-4p87 lists affected ranges: Go github.com/cli/cli/v2 >=0 =0 <2.62.0) Commands are suggestions: review each one before running it.
Loading voting…