Laravel environment manipulation via query string
CVE-2024-52301GHSA-gv7v-rgg6-548h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (laravel/framework 11.31.0, 10.48.23, 9.52.17, 8.83.28, 7.30.7, 6.20.45), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist laravel/framework
- Affected
- < 6.20.45>= 7.0.0, < 7.30.7>= 8.0.0, < 8.83.28>= 9.0.0, < 9.52.17>= 10.0.0, < 10.48.23>= 11.0.0, < 11.31.0
- Fixed in
- 9.52.17, 11.31.0, 10.48.23, 8.83.28, 7.30.7, 6.20.45
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gv7v-rgg6-548h lists affected ranges: Packagist laravel/framework >=0 =7.0.0 =8.0.0 =9.0.0 =10.0.0 =11.0.0 <11.31.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-52301: 44.76% estimated exploitation activity in the next 30 days; percentile 98.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description When the registerargcargv php directive is set to on , and users call any URL with a special crafted query string, they are able to change the environment used by the framework when handling the request. Resolution The framework now ignores argv values for environment detection on non-cli SAPIs.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-gv7v-rgg6-548h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-52301 Advisory: Laravel environment manipulation via query string IDs: CVE-2024-52301, GHSA-gv7v-rgg6-548h Record: https://patchnext.com/advisories/cve-2024-52301 (revision 1, source checked 26 Oct 2026, 14:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: laravel/framework 11.31.0, 10.48.23, 9.52.17, 8.83.28, 7.30.7, 6.20.45. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist laravel/framework: affected < 6.20.45; >= 7.0.0, < 7.30.7; >= 8.0.0, < 8.83.28; >= 9.0.0, < 9.52.17; >= 10.0.0, < 10.48.23; >= 11.0.0, < 11.31.0; fixed in 9.52.17, 11.31.0, 10.48.23, 8.83.28, 7.30.7, 6.20.45 ## Suggested inspection (read-only) - Packagist laravel/framework: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on laravel/framework. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-gv7v-rgg6-548h (GitHub-reviewed advisory GHSA-gv7v-rgg6-548h lists affected ranges: Packagist laravel/framework >=0 =7.0.0 =8.0.0 =9.0.0 =10.0.0 =11.0.0 <11.31.0) Commands are suggestions: review each one before running it.
Loading voting…