LibOSDP vulnerable to a null pointer deref in osdp_reply_name
CVE-2024-52296GHSA-7945-5mcv-f2pp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (libosdp 2.4.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI libosdp
- Affected
- < 2.4.0
- Fixed in
- 2.4.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7945-5mcv-f2pp lists affected ranges: PyPI libosdp >=0 <2.4.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7945-5mcv-f2pp lists affected ranges: PyPI libosdp >=0 <2.4.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2024-52296: 0.35% estimated exploitation activity in the next 30 days; percentile 28.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Issue: At ospdcommon.c, on the osdpreplyname function, any reply id between REPLYACK and REPLYXRD is valid, but names array do not declare all of the range. On a case of an undefined reply id within the range, name will be null (name = names[replyid - REPLYACK];). Null name will casue a crash on next line: if (name[0] == '\0') as null[0] is invalid. Attack: As this logic is not limited to a secure connection, attacker may trigger this vulnerability without any prior knowledge. Impact Denial of Service Patch The issue has been patched in 24409e98a260176765956ec766a04cb35984fab1
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-7945-5mcv-f2pp
- Revision 1 · created ·
Published from osv record GHSA-7945-5mcv-f2pp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-52296 Advisory: LibOSDP vulnerable to a null pointer deref in osdp_reply_name IDs: CVE-2024-52296, GHSA-7945-5mcv-f2pp Record: https://patchnext.com/advisories/cve-2024-52296 (revision 2, source checked 26 Oct 2026, 13:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: libosdp 2.4.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI libosdp: affected < 2.4.0; fixed in 2.4.0 ## Suggested inspection (read-only) - `python -m pip show libosdp`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on libosdp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7945-5mcv-f2pp (OSV record GHSA-7945-5mcv-f2pp lists affected ranges: PyPI libosdp >=0 <2.4.0 (fixed)) - Verified: https://github.com/advisories/GHSA-7945-5mcv-f2pp (GitHub-reviewed advisory GHSA-7945-5mcv-f2pp lists affected ranges: PyPI libosdp >=0 <2.4.0) Commands are suggestions: review each one before running it.
Loading voting…