Skip to content

← Actionable
High, CVSS 7.3

Craft CMS vulnerable to Potential Remote Code Execution via missing path normalization & Twig SSTI

CVE-2024-52293GHSA-f3cw-hg6r-chfv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (craftcms/cms 5.4.3, 4.12.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist craftcms/cms

    Affected
    >= 4.0.0-RC1, <= 4.12.1>= 5.0.0-RC1, <= 5.4.2
    Fixed in
    5.4.3, 4.12.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2024-52293: 1.36% estimated exploitation activity in the next 30 days; percentile 71.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Missing normalizePath in the function FileHelper::absolutePath could lead to Remote Code Execution on the server via twig SSTI. (Post-authentication, ALLOWADMINCHANGES=true) Details Note: This is a sequel to CVE-2023-40035 In src/helpers/FileHelper.php#L106-L137, the function absolutePath returned $from . $ds . $to without path normalization: This could leads to multiple security risks, one of them is in src/services/Security.php#L201-L220 where ../templates/poc is not considered a system dir. Let's see what happens after calling isSystemDir("../templates/poc"): Now that the path ../templates/poc can bypass isSystemDir, it will also bypass the function validatePath in src/fs/Local.php#L124-L136: We can now create a Local filesystem within the system directories, particularly in /var/www/html/templates/poc Then create a new asset volume with that filesystem, upload a poc.ttml file with twig code and execute using a new route with template path poc/poc.ttml Although craftcms…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-f3cw-hg6r-chfv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-52293

Advisory: Craft CMS vulnerable to Potential Remote Code Execution via missing path normalization & Twig SSTI
IDs: CVE-2024-52293, GHSA-f3cw-hg6r-chfv
Record: https://patchnext.com/advisories/cve-2024-52293 (revision 1, source checked 26 Oct 2026, 14:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: craftcms/cms 5.4.3, 4.12.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist craftcms/cms: affected >= 4.0.0-RC1, <= 4.12.1; >= 5.0.0-RC1, <= 5.4.2; fixed in 5.4.3, 4.12.2

## Suggested inspection (read-only)
- Packagist craftcms/cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on craftcms/cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-f3cw-hg6r-chfv (GitHub-reviewed advisory GHSA-f3cw-hg6r-chfv lists affected ranges: Packagist craftcms/cms >=4.0.0-RC1 =5.0.0-RC1 <=5.4.2)

Commands are suggestions: review each one before running it.

Loading voting…