Craft CMS Arbitrary System File Read
CVE-2024-52292GHSA-cw6g-qmjq-6w2w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (craftcms/cms 5.4.9, 4.12.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist craftcms/cms
- Affected
- >= 5.0.0-alpha.1, <= 5.4.7.1>= 3.5.13, <= 4.12.6.1
- Fixed in
- 4.12.8, 5.4.9
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cw6g-qmjq-6w2w lists affected ranges: Packagist craftcms/cms >=5.0.0-alpha.1 =3.5.13 <=4.12.6.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.0 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2024-52292: 0.75% estimated exploitation activity in the next 30 days; percentile 54.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary By abusing the mail notification template it is possible to read arbitrary operating system files. Details The dataUrl function can be exploited if an attacker has write permissions on system notification templates. This function accepts an absolute file path, reads the file's content, and converts it into a Base64-encoded string. By embedding this function within a system notification template, the attacker can exfiltrate the Base64-encoded file content through a triggered system email notification. Once the email is received, the Base64 payload can be decoded, allowing the attacker to read arbitrary files on the server. Requirements: write permissions to system notification templates ability to trigger a corresponding system email PoC 1) Modify a template to contain the following twig template string: 2) Trigger the corresponding notification email (e.g. by resetting a password) 3) Receive the email and decode the base64 string Mail received: Decoded string: Impact 1)…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-cw6g-qmjq-6w2w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-52292 Advisory: Craft CMS Arbitrary System File Read IDs: CVE-2024-52292, GHSA-cw6g-qmjq-6w2w Record: https://patchnext.com/advisories/cve-2024-52292 (revision 1, source checked 26 Oct 2026, 14:28 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: craftcms/cms 5.4.9, 4.12.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist craftcms/cms: affected >= 5.0.0-alpha.1, <= 5.4.7.1; >= 3.5.13, <= 4.12.6.1; fixed in 4.12.8, 5.4.9 ## Suggested inspection (read-only) - Packagist craftcms/cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on craftcms/cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-cw6g-qmjq-6w2w (GitHub-reviewed advisory GHSA-cw6g-qmjq-6w2w lists affected ranges: Packagist craftcms/cms >=5.0.0-alpha.1 =3.5.13 <=4.12.6.1) Commands are suggestions: review each one before running it.
Loading voting…