Skip to content

← Actionable
High, CVSS 7.2

Local File System Validation Bypass Leading to File Overwrite, Sensitive File Access, and Potential Code Execution

CVE-2024-52291GHSA-jrh5-vhr9-qh7q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (craftcms/cms 5.4.6, 4.12.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist craftcms/cms

    Affected
    >= 5.0.0-RC1, <= 5.4.5.1>= 4.0.0-RC1, <= 4.12.4.1
    Fixed in
    5.4.6, 4.12.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:P · score source
EPSS
  • CVE-2024-52291: 1.25% estimated exploitation activity in the next 30 days; percentile 69.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A vulnerability in CraftCMS allows an attacker to bypass local file system validation by utilizing a double file:// scheme (e.g., file://file:////). This enables the attacker to specify sensitive folders as the file system, leading to potential file overwriting through malicious uploads, unauthorized access to sensitive files, and, under certain conditions, remote code execution (RCE) via Server-Side Template Injection (SSTI) payloads. Note that this will only work if you have an authenticated administrator account with allowAdminChanges enabled. https://craftcms.com/knowledge-base/securing-craft#set-allowAdminChanges-to-false-in-production Details The issue lies in line 57 of cms/src/helpers/FileHelper.php, it only removes file:// on the most left. It is trivial to bypass this sanitization by adding 2 file://, e.g. file://file:////. PoC 1. Sign in with an admin account and navigate to Settings → Assets, then create a new volume. 2. n the Asset Filesystem section, create a…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jrh5-vhr9-qh7q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-52291

Advisory: Local File System Validation Bypass Leading to File Overwrite, Sensitive File Access, and Potential Code Execution
IDs: CVE-2024-52291, GHSA-jrh5-vhr9-qh7q
Record: https://patchnext.com/advisories/cve-2024-52291 (revision 1, source checked 26 Oct 2026, 14:28 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: craftcms/cms 5.4.6, 4.12.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist craftcms/cms: affected >= 5.0.0-RC1, <= 5.4.5.1; >= 4.0.0-RC1, <= 4.12.4.1; fixed in 5.4.6, 4.12.5

## Suggested inspection (read-only)
- Packagist craftcms/cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on craftcms/cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jrh5-vhr9-qh7q (GitHub-reviewed advisory GHSA-jrh5-vhr9-qh7q lists affected ranges: Packagist craftcms/cms >=5.0.0-RC1 =4.0.0-RC1 <=4.12.4.1)

Commands are suggestions: review each one before running it.

Loading voting…