Rancher UI has Stored Cross-site Scripting vulnerability
CVE-2024-52281GHSA-2v2w-8v8c-wcm9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/rancher/rancher 2.9.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 2.9.0, < 2.9.4
- Fixed in
- 2.9.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2v2w-8v8c-wcm9 lists affected ranges: Go github.com/rancher/rancher >=2.9.0 <2.9.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:L
- EPSS
- CVE-2024-52281: 0.56% estimated exploitation activity in the next 30 days; percentile 46.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A vulnerability has been identified within Rancher UI that allows a malicious actor to perform a Stored XSS attack through the cluster description field. Please consult the associated MITRE ATT&CK - Technique - Drive-by Compromise for further information about this category of attack. Patches The fix introduces new changes in the directives responsible for sanitizing HTML code before rendering. We replaced the v-tooltip directive with the v-clean-tooltip directive. Patched versions include releases 2.9.4 and 2.10.0. Workarounds There are no workarounds for this issue. Users are recommended to upgrade, as soon as possible, to a version of /Rancher Manager which contains the fixes. Credits This issue was identified and reported by Bhavin Makwana from Workday’s Cyber Defence Team. For more information If you have any questions or comments about this advisory: - Reach out to the SUSE Rancher Security team for security related inquiries. - Open an issue in the Rancher repository. -…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2v2w-8v8c-wcm9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-52281 Advisory: Rancher UI has Stored Cross-site Scripting vulnerability IDs: CVE-2024-52281, GHSA-2v2w-8v8c-wcm9 Record: https://patchnext.com/advisories/cve-2024-52281 (revision 1, source checked 26 Oct 2026, 15:09 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/rancher/rancher 2.9.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/rancher/rancher: affected >= 2.9.0, < 2.9.4; fixed in 2.9.4 ## Suggested inspection (read-only) - Go github.com/rancher/rancher: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/rancher/rancher. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2v2w-8v8c-wcm9 (GitHub-reviewed advisory GHSA-2v2w-8v8c-wcm9 lists affected ranges: Go github.com/rancher/rancher >=2.9.0 <2.9.4) Commands are suggestions: review each one before running it.
Loading voting…