scikit-learn sensitive data leakage vulnerability
CVE-2024-5206GHSA-jw8x-6495-233v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (scikit-learn 1.5.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI scikit-learn
- Affected
- < 1.5.0
- Fixed in
- 1.5.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jw8x-6495-233v lists affected ranges: PyPI scikit-learn >=0 <1.5.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jw8x-6495-233v lists affected ranges: PyPI scikit-learn >=0 <1.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2024-5206: 0.19% estimated exploitation activity in the next 30 days; percentile 8.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A sensitive data leakage vulnerability was identified in scikit-learn's TfidfVectorizer, specifically in versions up to and including 1.4.1.post1, which was fixed in version 1.5.0. The vulnerability arises from the unexpected storage of all tokens present in the training data within the stopwords attribute, rather than only storing the subset of tokens required for the TF-IDF technique to function. This behavior leads to the potential leakage of sensitive information, as the stopwords attribute could contain tokens that were meant to be discarded and not stored, such as passwords or keys. The impact of this vulnerability varies based on the nature of the data being processed by the vectorizer.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-jw8x-6495-233v
- Revision 1 · created ·
Published from osv record GHSA-jw8x-6495-233v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-5206 Advisory: scikit-learn sensitive data leakage vulnerability IDs: CVE-2024-5206, GHSA-jw8x-6495-233v Record: https://patchnext.com/advisories/cve-2024-5206 (revision 2, source checked 26 Oct 2026, 13:23 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: scikit-learn 1.5.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI scikit-learn: affected < 1.5.0; fixed in 1.5.0 ## Suggested inspection (read-only) - `python -m pip show scikit-learn`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on scikit-learn. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jw8x-6495-233v (OSV record GHSA-jw8x-6495-233v lists affected ranges: PyPI scikit-learn >=0 <1.5.0 (fixed)) - Verified: https://github.com/advisories/GHSA-jw8x-6495-233v (GitHub-reviewed advisory GHSA-jw8x-6495-233v lists affected ranges: PyPI scikit-learn >=0 <1.5.0) Commands are suggestions: review each one before running it.
Loading voting…