Skip to content

← Actionable
Medium, CVSS 6.6

Apache Solr Relative Path Traversal vulnerability

CVE-2024-52012GHSA-4p5m-gvpf-f3x5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.solr:solr-core 9.8.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:U · score source
EPSS
  • CVE-2024-52012: 47.12% estimated exploitation activity in the next 30 days; percentile 98.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Relative Path Traversal vulnerability in Apache Solr. Solr instances running on Windows are vulnerable to arbitrary filepath write-access, due to a lack of input-sanitation in the "configset upload" API. Commonly known as a "zipslip", maliciously constructed ZIP files can use relative filepaths to write data to unanticipated parts of the filesystem. This issue affects Apache Solr: from 6.6 through 9.7.0. Users are recommended to upgrade to version 9.8.0, which fixes the issue. Users unable to upgrade may also safely prevent the issue by using Solr's "Rule-Based Authentication Plugin" to restrict access to the configset upload API, so that it can only be accessed by a trusted set of administrators/users.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4p5m-gvpf-f3x5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-52012

Advisory: Apache Solr Relative Path Traversal vulnerability
IDs: CVE-2024-52012, GHSA-4p5m-gvpf-f3x5
Record: https://patchnext.com/advisories/cve-2024-52012 (revision 1, source checked 26 Oct 2026, 16:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.solr:solr-core 9.8.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.solr:solr-core: affected >= 6.6, < 9.8.0; fixed in 9.8.0

## Suggested inspection (read-only)
- Maven org.apache.solr:solr-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.solr:solr-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4p5m-gvpf-f3x5 (GitHub-reviewed advisory GHSA-4p5m-gvpf-f3x5 lists affected ranges: Maven org.apache.solr:solr-core >=6.6 <9.8.0)

Commands are suggestions: review each one before running it.

Loading voting…