Skip to content

← Actionable
High, CVSS 7.5amended

launch-editor vulnerable to command injection via the crafted request on Windows

CVE-2024-52011GHSA-c27g-q93r-2cwf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vite 5.4.9; launch-editor 2.9.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.5 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-52011: 0.51% estimated exploitation activity in the next 30 days; percentile 43.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Due to the insufficient sanitization of the file argument in the launchEditor, an attacker can execute arbitrary commands on Windows by supplying a filename that contains special characters. Impact If the following conditions are met, an attacker can execute arbitrary commands on the computer that is using the launch-editor: - An attacker can place a file with the malicious filename - An attacker can call the launchEditor method with the file argument controlled - The launch-editor package is running on Windows For example, some development server using this package satisfy these conditions, as a malicious website might be able to force the downloading of a file and the path of that file is predictable. Patch This issue has been fixed in the launch-editor version 2.9.0 (commit).

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-c27g-q93r-2cwf

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-c27g-q93r-2cwf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-52011

Advisory: launch-editor vulnerable to command injection via the crafted request on Windows
IDs: CVE-2024-52011, GHSA-c27g-q93r-2cwf
Record: https://patchnext.com/advisories/cve-2024-52011 (revision 3, source checked 26 Oct 2026, 12:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vite 5.4.9; launch-editor 2.9.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm vite: affected <= 5.4.8; fixed in 5.4.9
- npm launch-editor: affected <= 2.8.2; fixed in 2.9.0

## Suggested inspection (read-only)
- `npm ls vite --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls launch-editor --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vite, launch-editor.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-c27g-q93r-2cwf (OSV record GHSA-c27g-q93r-2cwf lists affected ranges: npm launch-editor >=0 =0 <5.4.9 (fixed))
- Verified: https://github.com/advisories/GHSA-c27g-q93r-2cwf (GitHub-reviewed advisory GHSA-c27g-q93r-2cwf lists affected ranges: npm launch-editor >=0 =0 <=5.4.8)

Commands are suggestions: review each one before running it.

Loading voting…