Password Policy Bypass Vulnerability in Fides Webserver User Accept Invite API
CVE-2024-52008GHSA-v7vm-rhmg-8j2r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ethyca-fides 2.50.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI ethyca-fides
- Affected
- < 2.50.0
- Fixed in
- 2.50.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-v7vm-rhmg-8j2r lists affected ranges: PyPI ethyca-fides >=0 <2.50.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v7vm-rhmg-8j2r lists affected ranges: PyPI ethyca-fides >=0 <2.50.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 1.9 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2024-52008: 0.56% estimated exploitation activity in the next 30 days; percentile 46.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The user invite acceptance API endpoint lacks server-side password policy enforcement, allowing users to set arbitrarily weak passwords by bypassing client-side validation. While the UI enforces password complexity requirements, direct API calls can circumvent these checks, enabling the creation of accounts with passwords as short as a single character. Details When an email messaging provider is enabled and a new user account is created in the system, an invite email containing a special link is sent to the new user's email address. This link directs the new user to a page where they can set their initial password. While the user interface implements password complexity checks, these validations are only performed client-side. The underlying /api/v1/user/accept-invite API endpoint does not implement the same password policy validations. Impact This vulnerability allows an invited user to set an extremely weak password for their own account during the initial account setup…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-v7vm-rhmg-8j2r
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-v7vm-rhmg-8j2r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-52008 Advisory: Password Policy Bypass Vulnerability in Fides Webserver User Accept Invite API IDs: CVE-2024-52008, GHSA-v7vm-rhmg-8j2r Record: https://patchnext.com/advisories/cve-2024-52008 (revision 3, source checked 26 Oct 2026, 13:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 1.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ethyca-fides 2.50.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI ethyca-fides: affected < 2.50.0; fixed in 2.50.0 ## Suggested inspection (read-only) - `python -m pip show ethyca-fides`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ethyca-fides. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-v7vm-rhmg-8j2r (OSV record GHSA-v7vm-rhmg-8j2r lists affected ranges: PyPI ethyca-fides >=0 <2.50.0 (fixed)) - Verified: https://github.com/advisories/GHSA-v7vm-rhmg-8j2r (GitHub-reviewed advisory GHSA-v7vm-rhmg-8j2r lists affected ranges: PyPI ethyca-fides >=0 <2.50.0) Commands are suggestions: review each one before running it.
Loading voting…