Skip to content

← Actionable
High, CVSS 7.7

XXE vulnerability in XSLT parsing in org.hl7.fhir.core

CVE-2024-52007GHSA-gr3c-q7xf-47vh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ca.uhn.hapi.fhir:org.hl7.fhir.dstu2016may 6.4.0; ca.uhn.hapi.fhir:org.hl7.fhir.dstu3 6.4.0; ca.uhn.hapi.fhir:org.hl7.fhir.r4b 6.4.0; ca.uhn.hapi.fhir:org.hl7.fhir.utilities 6.4.0; ca.uhn.hapi.fhir:org.hl7.fhir.r4 6.4.0; 1 more package under Affected packages), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N · score source
EPSS
  • CVE-2024-52007: 0.90% estimated exploitation activity in the next 30 days; percentile 59.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary XSLT parsing performed by various components are vulnerable to XML external entity injections. A processed XML file with a malicious DTD tag ( <!DOCTYPE foo [<!ENTITY example SYSTEM "/etc/passwd" ] could produce XML containing data from the host system. This impacts use cases where org.hl7.fhir.core is being used to within a host where external clients can submit XML. Details This is related to https://github.com/hapifhir/org.hl7.fhir.core/security/advisories/GHSA-6cr6-ph3p-f5rf, in which its fix ( https://github.com/hapifhir/org.hl7.fhir.core/issues/1571, https://github.com/hapifhir/org.hl7.fhir.core/pull/1717) was incomplete. References https://cwe.mitre.org/data/definitions/611.html https://cheatsheetseries.owasp.org/cheatsheets/XMLExternalEntityPreventionCheatSheet.html#jaxp-documentbuilderfactory-saxparserfactory-and-dom4j

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gr3c-q7xf-47vh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-52007

Advisory: XXE vulnerability in XSLT parsing in `org.hl7.fhir.core`
IDs: CVE-2024-52007, GHSA-gr3c-q7xf-47vh
Record: https://patchnext.com/advisories/cve-2024-52007 (revision 1, source checked 26 Oct 2026, 16:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ca.uhn.hapi.fhir:org.hl7.fhir.dstu2016may 6.4.0; ca.uhn.hapi.fhir:org.hl7.fhir.dstu3 6.4.0; ca.uhn.hapi.fhir:org.hl7.fhir.r4b 6.4.0; ca.uhn.hapi.fhir:org.hl7.fhir.utilities 6.4.0; ca.uhn.hapi.fhir:org.hl7.fhir.r4 6.4.0; ca.uhn.hapi.fhir:org.hl7.fhir.r5 6.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven ca.uhn.hapi.fhir:org.hl7.fhir.dstu2016may: affected < 6.4.0; fixed in 6.4.0
- Maven ca.uhn.hapi.fhir:org.hl7.fhir.dstu3: affected < 6.4.0; fixed in 6.4.0
- Maven ca.uhn.hapi.fhir:org.hl7.fhir.r4b: affected < 6.4.0; fixed in 6.4.0
- Maven ca.uhn.hapi.fhir:org.hl7.fhir.utilities: affected < 6.4.0; fixed in 6.4.0
- Maven ca.uhn.hapi.fhir:org.hl7.fhir.r4: affected < 6.4.0; fixed in 6.4.0
- Maven ca.uhn.hapi.fhir:org.hl7.fhir.r5: affected < 6.4.0; fixed in 6.4.0

## Suggested inspection (read-only)
- Maven ca.uhn.hapi.fhir:org.hl7.fhir.dstu2016may: check the installed version with your package manager.
- Maven ca.uhn.hapi.fhir:org.hl7.fhir.dstu3: check the installed version with your package manager.
- Maven ca.uhn.hapi.fhir:org.hl7.fhir.r4b: check the installed version with your package manager.
- Maven ca.uhn.hapi.fhir:org.hl7.fhir.utilities: check the installed version with your package manager.
- Maven ca.uhn.hapi.fhir:org.hl7.fhir.r4: check the installed version with your package manager.
- Maven ca.uhn.hapi.fhir:org.hl7.fhir.r5: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ca.uhn.hapi.fhir:org.hl7.fhir.dstu2016may, ca.uhn.hapi.fhir:org.hl7.fhir.dstu3, ca.uhn.hapi.fhir:org.hl7.fhir.r4b, ca.uhn.hapi.fhir:org.hl7.fhir.utilities, ca.uhn.hapi.fhir:org.hl7.fhir.r4, ca.uhn.hapi.fhir:org.hl7.fhir.r5.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gr3c-q7xf-47vh (GitHub-reviewed advisory GHSA-gr3c-q7xf-47vh lists affected ranges: Maven ca.uhn.hapi.fhir:org.hl7.fhir.dstu3 >=0 =0 =0 =0 =0 =0 <6.4.0)

Commands are suggestions: review each one before running it.

Loading voting…