Symfony has an Authentication Bypass via RememberMe
CVE-2024-51996GHSA-cg23-qf8f-62rr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (symfony/security-http 7.1.8, 6.4.15, 5.4.47), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist symfony/security-http
- Affected
- >= 5.3.0, < 5.4.47>= 6.0.0-BETA1, < 6.4.15>= 7.0.0-BETA1, < 7.1.8
- Fixed in
- 6.4.15, 5.4.47, 7.1.8
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cg23-qf8f-62rr lists affected ranges: Packagist symfony/security-http >=5.3.0 =6.0.0-BETA1 =7.0.0-BETA1 <7.1.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-51996: 0.62% estimated exploitation activity in the next 30 days; percentile 49.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description When consuming a persisted remember-me cookie, Symfony does not check if the username persisted in the database matches the username attached with the cookie, leading to authentication bypass. Resolution The PersistentRememberMeHandler class now ensures the submitted username is the cookie owner. The patch for this issue is available here for branch 5.4. Credits We would like to thank Moritz Rauch - Pentryx AG for reporting the issue and Jérémy Derussé for providing the fix.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-cg23-qf8f-62rr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-51996 Advisory: Symfony has an Authentication Bypass via RememberMe IDs: CVE-2024-51996, GHSA-cg23-qf8f-62rr Record: https://patchnext.com/advisories/cve-2024-51996 (revision 1, source checked 26 Oct 2026, 14:28 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: symfony/security-http 7.1.8, 6.4.15, 5.4.47. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist symfony/security-http: affected >= 5.3.0, < 5.4.47; >= 6.0.0-BETA1, < 6.4.15; >= 7.0.0-BETA1, < 7.1.8; fixed in 6.4.15, 5.4.47, 7.1.8 ## Suggested inspection (read-only) - Packagist symfony/security-http: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on symfony/security-http. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-cg23-qf8f-62rr (GitHub-reviewed advisory GHSA-cg23-qf8f-62rr lists affected ranges: Packagist symfony/security-http >=5.3.0 =6.0.0-BETA1 =7.0.0-BETA1 <7.1.8) Commands are suggestions: review each one before running it.
Loading voting…