Skip to content

← Actionable
Critical, CVSS 9.2

jj vulnerable to path traversal via crafted Git repositories

CVE-2024-51990GHSA-88h5-6w7m-5w56

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (jj-lib 0.23.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io jj-lib

    Affected
    < 0.23.0
    Fixed in
    0.23.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.2 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:H/SA:N · score source
EPSS
  • CVE-2024-51990: 0.61% estimated exploitation activity in the next 30 days; percentile 49.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Specially crafted Git repositories can cause jj to write files outside the clone. Patches Fixed in 0.23.0. Workarounds Not much other than to not clone repositories from untrusted sources. References Here's the original report from @joernchen: When cloning a crafted Git repository it is possible to let jj write into arbitrary directories. This can be achieved by having file objects which contain path traversals. Reproduction steps: Apply the following patch to Git version v.2.47.0: With this patched git binary we can now apply a crafted patch containing a path traversal to a repository. The patch would look like: Note the traversal ../joernchenwashere in the patch. This now can be committed to a repository using the modified git binary: Now, when cloning that repository with jj git clone the path traversal will write above the worktree directory, allowing arbitrary file writes. I've attached a tar.gz with the demo repo so you don't have to mess with the patched Git at all. For…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-88h5-6w7m-5w56

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-51990

Advisory: jj vulnerable to path traversal via crafted Git repositories
IDs: CVE-2024-51990, GHSA-88h5-6w7m-5w56
Record: https://patchnext.com/advisories/cve-2024-51990 (revision 1, source checked 26 Oct 2026, 15:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: jj-lib 0.23.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io jj-lib: affected < 0.23.0; fixed in 0.23.0

## Suggested inspection (read-only)
- crates.io jj-lib: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on jj-lib.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-88h5-6w7m-5w56 (GitHub-reviewed advisory GHSA-88h5-6w7m-5w56 lists affected ranges: crates.io jj-lib >=0 <0.23.0)

Commands are suggestions: review each one before running it.

Loading voting…