Skip to content

← Actionable
High, CVSS 8.8amended

onnx allows Arbitrary File Overwrite in download_model_with_test_data

CVE-2024-5187GHSA-6rq9-53c3-f7vj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (onnx 1.16.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI onnx

    Affected
    < 1.16.2
    Fixed in
    1.16.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2024-5187: 1.17% estimated exploitation activity in the next 30 days; percentile 67.42 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
  • CVE-2025-51480: 0.68% estimated exploitation activity in the next 30 days; percentile 52.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A vulnerability in the downloadmodelwithtestdata function of the onnx/onnx framework, versions before 1.16.2, allow for arbitrary file overwrite due to inadequate prevention of path traversal attacks in malicious tar files. This vulnerability enables attackers to overwrite any file on the system, potentially leading to remote code execution, deletion of system, personal, or application files, thus impacting the integrity and availability of the system. The issue arises from the function's handling of tar file extraction without performing security checks on the paths within the tar file, as demonstrated by the ability to overwrite the /home/kali/.ssh/authorizedkeys file by specifying an absolute path in the malicious tar file.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-6rq9-53c3-f7vj

  2. Revision 1 · created ·

    Published from osv record GHSA-6rq9-53c3-f7vj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-5187

Advisory: onnx allows Arbitrary File Overwrite in download_model_with_test_data
IDs: CVE-2024-5187, GHSA-6rq9-53c3-f7vj
Record: https://patchnext.com/advisories/cve-2024-5187 (revision 2, source checked 26 Oct 2026, 13:44 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: onnx 1.16.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI onnx: affected < 1.16.2; fixed in 1.16.2

## Suggested inspection (read-only)
- `python -m pip show onnx`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on onnx.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6rq9-53c3-f7vj (OSV record GHSA-6rq9-53c3-f7vj lists affected ranges: PyPI onnx >=0 <1.16.2 (fixed))
- Verified: https://github.com/advisories/GHSA-6rq9-53c3-f7vj (GitHub-reviewed advisory GHSA-6rq9-53c3-f7vj lists affected ranges: PyPI onnx >=0 <1.16.2)

Commands are suggestions: review each one before running it.

Loading voting…