Skip to content

← Actionable
Medium, CVSS 6.5

Eclipse Ditto vulnerable to Cross-site Scripting

CVE-2024-5165GHSA-hjfc-6jxr-j2rx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.eclipse.ditto:ditto 3.5.6, 3.4.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2024-5165: 0.50% estimated exploitation activity in the next 30 days; percentile 42.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In Eclipse Ditto starting in version 3.0.0 and prior to versions 3.4.5 and 3.5.6, the user input of several input fields of the Eclipse Ditto Explorer User Interface https://eclipse.dev/ditto/user-interface.html was not properly neutralized and thus vulnerable to both Reflected and Stored XSS (Cross Site Scripting). Several inputs were not persisted at the backend of Eclipse Ditto, but only in local browser storage to save settings of "environments" of the UI and e.g. the last performed "search queries", resulting in a "Reflected XSS" vulnerability. However, several other inputs were persisted at the backend of Eclipse Ditto, leading to a "Stored XSS" vulnerability. Those mean that authenticated and authorized users at Eclipse Ditto can persist Things in Ditto which can - when being displayed by other users also being authorized to see those Things in the Eclipse Ditto UI - cause scripts to be executed in the browser of other users.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-hjfc-6jxr-j2rx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-5165

Advisory: Eclipse Ditto vulnerable to Cross-site Scripting
IDs: CVE-2024-5165, GHSA-hjfc-6jxr-j2rx
Record: https://patchnext.com/advisories/cve-2024-5165 (revision 1, source checked 26 Oct 2026, 16:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.eclipse.ditto:ditto 3.5.6, 3.4.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.eclipse.ditto:ditto: affected >= 3.0.0, < 3.4.5; >= 3.5.0, < 3.5.6; fixed in 3.5.6, 3.4.5

## Suggested inspection (read-only)
- Maven org.eclipse.ditto:ditto: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.eclipse.ditto:ditto.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hjfc-6jxr-j2rx (GitHub-reviewed advisory GHSA-hjfc-6jxr-j2rx lists affected ranges: Maven org.eclipse.ditto:ditto >=3.0.0 =3.5.0 <3.5.6)

Commands are suggestions: review each one before running it.

Loading voting…