Skip to content

← Actionable
High, CVSS 8.8

Apache ZooKeeper: Authentication bypass with IP-based authentication in Admin Server

CVE-2024-51504GHSA-g93m-8x6h-g5gv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.zookeeper:zookeeper 3.9.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-51504: 0.92% estimated exploitation activity in the next 30 days; percentile 60.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

When using IPAuthenticationProvider in ZooKeeper Admin Server there is a possibility of Authentication Bypass by Spoofing -- this only impacts IP based authentication implemented in ZooKeeper Admin Server. Default configuration of client's IP address detection in IPAuthenticationProvider, which uses HTTP request headers, is weak and allows an attacker to bypass authentication via spoofing client's IP address in request headers. Default configuration honors X-Forwarded-For HTTP header to read client's IP address. X-Forwarded-For request header is mainly used by proxy servers to identify the client and can be easily spoofed by an attacker pretending that the request comes from a different IP address. Admin Server commands, such as snapshot and restore arbitrarily can be executed on successful exploitation which could potentially lead to information leakage or service availability issues. Users are recommended to upgrade to version 3.9.3, which fixes this issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-g93m-8x6h-g5gv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-51504

Advisory: Apache ZooKeeper: Authentication bypass with IP-based authentication in Admin Server
IDs: CVE-2024-51504, GHSA-g93m-8x6h-g5gv
Record: https://patchnext.com/advisories/cve-2024-51504 (revision 1, source checked 26 Oct 2026, 16:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.zookeeper:zookeeper 3.9.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.zookeeper:zookeeper: affected >= 3.9.0, < 3.9.3; fixed in 3.9.3

## Suggested inspection (read-only)
- Maven org.apache.zookeeper:zookeeper: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.zookeeper:zookeeper.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-g93m-8x6h-g5gv (GitHub-reviewed advisory GHSA-g93m-8x6h-g5gv lists affected ranges: Maven org.apache.zookeeper:zookeeper >=3.9.0 <3.9.3)

Commands are suggestions: review each one before running it.

Loading voting…