Skip to content

← Actionable
Medium, CVSS 4.0

CVE-2024-5138: snapd snapctl auth bypass

CVE-2024-5138GHSA-p9v8-q5m4-pf46

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/snapcore/snapd 2.63.1, 0.0.0-20240524114846-68ee9c6aa916), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/snapcore/snapd

    Affected
    >= 2.51.6, < 2.63.1< 0.0.0-20240524114846-68ee9c6aa916
    Fixed in
    2.63.1, 0.0.0-20240524114846-68ee9c6aa916

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.0 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2024-5138: 0.83% estimated exploitation activity in the next 30 days; percentile 57.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A snap with prior permissions to create a mount entry on the host, such as firefox, normally uses the permission from one of the per-snap hook programs. A unprivileged users cannot normally trigger that behaviour by using snap run --shell firefox followed by snapctl mount, since snapd validates the requesting user identity (root or non-root). The issue allows unprivileged users to bypass that check by crafting a malicious command line vector which confuses snapd into thinking the help message is requested. Unprivileged user on a default installation of Ubuntu, where firefox is as provided as a snap, may cause a denial-of-service attack by repeatedly mounting hunspell database over and over and eventually exhausting system memory. Other attacks, reliant on the same underying mechanism (mount), are possible. In all cases the snap must be installed and grated permission to perform this action (by connecting an appropriate snap interface), which requires administrative privileges.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-p9v8-q5m4-pf46

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-5138

Advisory: CVE-2024-5138: snapd snapctl auth bypass
IDs: CVE-2024-5138, GHSA-p9v8-q5m4-pf46
Record: https://patchnext.com/advisories/cve-2024-5138 (revision 1, source checked 26 Oct 2026, 15:08 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/snapcore/snapd 2.63.1, 0.0.0-20240524114846-68ee9c6aa916. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/snapcore/snapd: affected >= 2.51.6, < 2.63.1; < 0.0.0-20240524114846-68ee9c6aa916; fixed in 2.63.1, 0.0.0-20240524114846-68ee9c6aa916

## Suggested inspection (read-only)
- Go github.com/snapcore/snapd: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/snapcore/snapd.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-p9v8-q5m4-pf46 (GitHub-reviewed advisory GHSA-p9v8-q5m4-pf46 lists affected ranges: Go github.com/snapcore/snapd >=2.51.6 =0 <0.0.0-20240524114846-68ee9c6aa916)

Commands are suggestions: review each one before running it.

Loading voting…