HAPI FHIR XML External Entity (XXE) vulnerability
CVE-2024-51132GHSA-4cf2-cxp3-rjr7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ca.uhn.hapi.fhir:org.hl7.fhir.convertors 6.4.0; ca.uhn.hapi.fhir:org.hl7.fhir.dstu2016may 6.4.0; ca.uhn.hapi.fhir:org.hl7.fhir.dstu3 6.4.0; ca.uhn.hapi.fhir:org.hl7.fhir.validation 6.4.0; ca.uhn.hapi.fhir:org.hl7.fhir.r4b 6.4.0; 4 more packages under Affected packages), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven ca.uhn.hapi.fhir:org.hl7.fhir.convertors
- Affected
- < 6.4.0
- Fixed in
- 6.4.0
Maven ca.uhn.hapi.fhir:org.hl7.fhir.dstu2016may
- Affected
- < 6.4.0
- Fixed in
- 6.4.0
Maven ca.uhn.hapi.fhir:org.hl7.fhir.dstu3
- Affected
- < 6.4.0
- Fixed in
- 6.4.0
Maven ca.uhn.hapi.fhir:org.hl7.fhir.validation
- Affected
- < 6.4.0
- Fixed in
- 6.4.0
Maven ca.uhn.hapi.fhir:org.hl7.fhir.r4b
- Affected
- < 6.4.0
- Fixed in
- 6.4.0
Maven ca.uhn.hapi.fhir:org.hl7.fhir.utilities
- Affected
- < 6.4.0
- Fixed in
- 6.4.0
Maven ca.uhn.hapi.fhir:org.hl7.fhir.r4
- Affected
- < 6.4.0
- Fixed in
- 6.4.0
Maven ca.uhn.hapi.fhir:org.hl7.fhir.dstu2
- Affected
- < 6.4.0
- Fixed in
- 6.4.0
Maven ca.uhn.hapi.fhir:org.hl7.fhir.r5
- Affected
- < 6.4.0
- Fixed in
- 6.4.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4cf2-cxp3-rjr7 lists affected ranges: Maven ca.uhn.hapi.fhir:org.hl7.fhir.convertors >=0 =0 =0 =0 =0 =0 =0 =0…
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2024-51132: 1.90% estimated exploitation activity in the next 30 days; percentile 79.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An XML External Entity (XXE) vulnerability in HAPI FHIR before v6.4.0 allows attackers to access sensitive information or execute arbitrary code via supplying a crafted request containing malicious XML entities.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4cf2-cxp3-rjr7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-51132 Advisory: HAPI FHIR XML External Entity (XXE) vulnerability IDs: CVE-2024-51132, GHSA-4cf2-cxp3-rjr7 Record: https://patchnext.com/advisories/cve-2024-51132 (revision 1, source checked 26 Oct 2026, 16:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ca.uhn.hapi.fhir:org.hl7.fhir.convertors 6.4.0; ca.uhn.hapi.fhir:org.hl7.fhir.dstu2016may 6.4.0; ca.uhn.hapi.fhir:org.hl7.fhir.dstu3 6.4.0; ca.uhn.hapi.fhir:org.hl7.fhir.validation 6.4.0; ca.uhn.hapi.fhir:org.hl7.fhir.r4b 6.4.0; ca.uhn.hapi.fhir:org.hl7.fhir.utilities 6.4.0; ca.uhn.hapi.fhir:org.hl7.fhir.r4 6.4.0; ca.uhn.hapi.fhir:org.hl7.fhir.dstu2 6.4.0; ca.uhn.hapi.fhir:org.hl7.fhir.r5 6.4.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven ca.uhn.hapi.fhir:org.hl7.fhir.convertors: affected < 6.4.0; fixed in 6.4.0 - Maven ca.uhn.hapi.fhir:org.hl7.fhir.dstu2016may: affected < 6.4.0; fixed in 6.4.0 - Maven ca.uhn.hapi.fhir:org.hl7.fhir.dstu3: affected < 6.4.0; fixed in 6.4.0 - Maven ca.uhn.hapi.fhir:org.hl7.fhir.validation: affected < 6.4.0; fixed in 6.4.0 - Maven ca.uhn.hapi.fhir:org.hl7.fhir.r4b: affected < 6.4.0; fixed in 6.4.0 - Maven ca.uhn.hapi.fhir:org.hl7.fhir.utilities: affected < 6.4.0; fixed in 6.4.0 - Maven ca.uhn.hapi.fhir:org.hl7.fhir.r4: affected < 6.4.0; fixed in 6.4.0 - Maven ca.uhn.hapi.fhir:org.hl7.fhir.dstu2: affected < 6.4.0; fixed in 6.4.0 - Maven ca.uhn.hapi.fhir:org.hl7.fhir.r5: affected < 6.4.0; fixed in 6.4.0 ## Suggested inspection (read-only) - Maven ca.uhn.hapi.fhir:org.hl7.fhir.convertors: check the installed version with your package manager. - Maven ca.uhn.hapi.fhir:org.hl7.fhir.dstu2016may: check the installed version with your package manager. - Maven ca.uhn.hapi.fhir:org.hl7.fhir.dstu3: check the installed version with your package manager. - Maven ca.uhn.hapi.fhir:org.hl7.fhir.validation: check the installed version with your package manager. - Maven ca.uhn.hapi.fhir:org.hl7.fhir.r4b: check the installed version with your package manager. - Maven ca.uhn.hapi.fhir:org.hl7.fhir.utilities: check the installed version with your package manager. - Maven ca.uhn.hapi.fhir:org.hl7.fhir.r4: check the installed version with your package manager. - Maven ca.uhn.hapi.fhir:org.hl7.fhir.dstu2: check the installed version with your package manager. - Maven ca.uhn.hapi.fhir:org.hl7.fhir.r5: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ca.uhn.hapi.fhir:org.hl7.fhir.convertors, ca.uhn.hapi.fhir:org.hl7.fhir.dstu2016may, ca.uhn.hapi.fhir:org.hl7.fhir.dstu3, ca.uhn.hapi.fhir:org.hl7.fhir.validation, ca.uhn.hapi.fhir:org.hl7.fhir.r4b, ca.uhn.hapi.fhir:org.hl7.fhir.utilities, ca.uhn.hapi.fhir:org.hl7.fhir.r4, ca.uhn.hapi.fhir:org.hl7.fhir.dstu2, ca.uhn.hapi.fhir:org.hl7.fhir.r5. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4cf2-cxp3-rjr7 (GitHub-reviewed advisory GHSA-4cf2-cxp3-rjr7 lists affected ranges: Maven ca.uhn.hapi.fhir:org.hl7.fhir.convertors >=0 =0 =0 =0 =0 =0 =0 =0…) Commands are suggestions: review each one before running it.
Loading voting…