Skip to content

← Actionable
High, CVSS 7.2

LibreNMS has a Persistent XSS from Insecure Input Sanitization Affects Multiple Endpoints

CVE-2024-50355GHSA-4m5r-w2rq-q54q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (librenms/librenms 24.10.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.2 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2024-50355: 0.34% estimated exploitation activity in the next 30 days; percentile 27.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The application fail to sanitising inputs properly and rendering the code from user input to browser which allow an attacker to execute malicious javascript code. Details User with Admin role can edit the Display Name of a device, the application did not properly sanitize the user input in the device Display Name, if java script code is inside the name of the device Display Name, its can be trigger from different sources. PoC 1. Use an Admin role user to change the Display Name of a device into the payload <img src="x" onerror="alert(document.cookie)" 2.1. Go to manage user and choose Manage Access 2.2. A pop-up will show 3.1. Create a new Alert Rule where it will check if the device is up or down by using ICMP and then add the rule to the device. 3.2. Once the device is down, there will be an alert in the Alerts Notifications 3.3. Hover over the Hostname will see a pop-up. 4.1. The same can be trigger in the Alert History once hover over the Device field. 5.1. The same can…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4m5r-w2rq-q54q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-50355

Advisory: LibreNMS has a Persistent XSS from Insecure Input Sanitization Affects Multiple Endpoints
IDs: CVE-2024-50355, GHSA-4m5r-w2rq-q54q
Record: https://patchnext.com/advisories/cve-2024-50355 (revision 1, source checked 26 Oct 2026, 14:28 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: librenms/librenms 24.10.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist librenms/librenms: affected <= 24.9.0; fixed in 24.10.0

## Suggested inspection (read-only)
- Packagist librenms/librenms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on librenms/librenms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4m5r-w2rq-q54q (GitHub-reviewed advisory GHSA-4m5r-w2rq-q54q lists affected ranges: Packagist librenms/librenms >=0 <=24.9.0)

Commands are suggestions: review each one before running it.

Loading voting…