LibreNMS has a Reflected XSS ('Cross-site Scripting') in librenms/includes/functions.php
CVE-2024-50351GHSA-v7w9-63xh-6r3w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (librenms/librenms 24.10.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist librenms/librenms
- Affected
- <= 24.9.1
- Fixed in
- 24.10.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v7w9-63xh-6r3w lists affected ranges: Packagist librenms/librenms >=0 <=24.9.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:L/A:L
- EPSS
- CVE-2024-50351: 0.43% estimated exploitation activity in the next 30 days; percentile 36.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A Reflected Cross-Site Scripting (XSS) vulnerability in the "section" parameter of the "logs" tab of a device allows attackers to inject arbitrary JavaScript. This vulnerability results in the execution of malicious code when a user accesses the page with a malicious "section" parameter, potentially compromising their session and enabling unauthorized actions. The issue arises from a lack of sanitization in the "reportthis()" function. Details The "section" parameter of the "logs" tab is vulnerable to reflected XSS. An attacker can inject the following XSS payload into the "section" parameter: When the page is loaded with this malicious parameter, the script executes immediately. This vulnerability occurs due to the lack of sanitization in the "reportthis()" function. Other endpoints using this same function may also be vulnerable. The vulnerable sink is located here:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-v7w9-63xh-6r3w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-50351
Advisory: LibreNMS has a Reflected XSS ('Cross-site Scripting') in librenms/includes/functions.php
IDs: CVE-2024-50351, GHSA-v7w9-63xh-6r3w
Record: https://patchnext.com/advisories/cve-2024-50351 (revision 1, source checked 26 Oct 2026, 14:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: librenms/librenms 24.10.0. A vendor fix does not mean a deployment is fixed.
## Affected components
- Packagist librenms/librenms: affected <= 24.9.1; fixed in 24.10.0
## Suggested inspection (read-only)
- Packagist librenms/librenms: check the installed version with your package manager.
## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.
## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on librenms/librenms.
- Repeat the inspection and confirm that only fixed versions remain installed.
## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.
## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.
## Sources
- Verified: https://github.com/advisories/GHSA-v7w9-63xh-6r3w (GitHub-reviewed advisory GHSA-v7w9-63xh-6r3w lists affected ranges: Packagist librenms/librenms >=0 <=24.9.1)
Commands are suggestions: review each one before running it.Loading voting…