Skip to content

← Actionable
Low, CVSS 2.3

Symfony vulnerable to open redirect via browser-sanitized URLs

CVE-2024-50345GHSA-mrqx-rp3w-jpjp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (symfony/http-foundation 7.1.7, 6.4.14, 5.4.46), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-50345: 0.59% estimated exploitation activity in the next 30 days; percentile 48.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description The Request class, does not parse URI with special characters the same way browsers do. As a result, an attacker can trick a validator relying on the Request class to redirect users to another domain. Resolution The Request::create methods now assert the URI does not contain invalid characters as defined by https://url.spec.whatwg.org/ The patch for this issue is available here for branch 5.4. Credits We would like to thank Sam Mush - IPASSLab && ZGC Lab for reporting the issue and Nicolas Grekas for providing the fix.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-mrqx-rp3w-jpjp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-50345

Advisory: Symfony vulnerable to open redirect via browser-sanitized URLs
IDs: CVE-2024-50345, GHSA-mrqx-rp3w-jpjp
Record: https://patchnext.com/advisories/cve-2024-50345 (revision 1, source checked 26 Oct 2026, 14:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: symfony/http-foundation 7.1.7, 6.4.14, 5.4.46. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist symfony/http-foundation: affected < 5.4.46; >= 6.0.0, < 6.4.14; >= 7.0.0, < 7.1.7; fixed in 5.4.46, 6.4.14, 7.1.7

## Suggested inspection (read-only)
- Packagist symfony/http-foundation: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on symfony/http-foundation.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-mrqx-rp3w-jpjp (GitHub-reviewed advisory GHSA-mrqx-rp3w-jpjp lists affected ranges: Packagist symfony/http-foundation >=0 =6.0.0 =7.0.0 <7.1.7)

Commands are suggestions: review each one before running it.

Loading voting…