matrix-js-sdk has insufficient MXC URI validation which allows client-side path traversal
CVE-2024-50336GHSA-xvg8-m4x3-w6xr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (matrix-js-sdk 34.11.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm matrix-js-sdk
- Affected
- < 34.11.1
- Fixed in
- 34.11.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xvg8-m4x3-w6xr lists affected ranges: npm matrix-js-sdk >=0 <34.11.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xvg8-m4x3-w6xr lists affected ranges: npm matrix-js-sdk >=0 <34.11.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:L/SA:N · score source
- EPSS
- CVE-2024-50336: 0.83% estimated exploitation activity in the next 30 days; percentile 57.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary matrix-js-sdk before 34.11.0 is vulnerable to client-side path traversal via crafted MXC URIs. A malicious room member can trigger clients based on the matrix-js-sdk to issue arbitrary authenticated GET requests to the client's homeserver. Details The Matrix specification demands homeservers to perform validation of the server-name and media-id components of MXC URIs with the intent to prevent path traversal. However, it is not mentioned that a similar check must also be performed on the client to prevent client-side path traversal. matrix-js-sdk fails to perform this validation. Patches Fixed in matrix-js-sdk 34.11.1. Workarounds None. References - https://spec.matrix.org/v1.12/client-server-api/#security-considerations-5 - https://blog.doyensec.com/2024/07/02/cspt2csrf.html
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-xvg8-m4x3-w6xr
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-xvg8-m4x3-w6xr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-50336 Advisory: matrix-js-sdk has insufficient MXC URI validation which allows client-side path traversal IDs: CVE-2024-50336, GHSA-xvg8-m4x3-w6xr Record: https://patchnext.com/advisories/cve-2024-50336 (revision 3, source checked 26 Oct 2026, 12:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: matrix-js-sdk 34.11.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm matrix-js-sdk: affected < 34.11.1; fixed in 34.11.1 ## Suggested inspection (read-only) - `npm ls matrix-js-sdk --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on matrix-js-sdk. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-xvg8-m4x3-w6xr (OSV record GHSA-xvg8-m4x3-w6xr lists affected ranges: npm matrix-js-sdk >=0 <34.11.1 (fixed)) - Verified: https://github.com/advisories/GHSA-xvg8-m4x3-w6xr (GitHub-reviewed advisory GHSA-xvg8-m4x3-w6xr lists affected ranges: npm matrix-js-sdk >=0 <34.11.1) Commands are suggestions: review each one before running it.
Loading voting…