MPXJ has a Potential Path Traversal Vulnerability
CVE-2024-49771GHSA-j945-c44v-97g6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mpxj.net 13.5.1; net.sf.mpxj 13.5.1; mpxj 13.5.1; net.sf.mpxj:mpxj 13.5.1; net.sf.mpxj-for-vb 13.5.1; 2 more packages under Affected packages), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
NuGet mpxj.net
- Affected
- >= 13.0.0, < 13.5.1
- Fixed in
- 13.5.1
NuGet net.sf.mpxj
- Affected
- >= 8.3.5, < 13.5.1
- Fixed in
- 13.5.1
RubyGems mpxj
- Affected
- >= 8.3.5, < 13.5.1
- Fixed in
- 13.5.1
Maven net.sf.mpxj:mpxj
- Affected
- >= 8.3.5, < 13.5.1
- Fixed in
- 13.5.1
NuGet net.sf.mpxj-for-vb
- Affected
- >= 8.3.5, < 13.5.1
- Fixed in
- 13.5.1
PyPI mpxj
- Affected
- >= 8.3.5, < 13.5.1
- Fixed in
- 13.5.1
NuGet net.sf.mpxj-for-csharp
- Affected
- >= 8.3.5, < 13.5.1
- Fixed in
- 13.5.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-j945-c44v-97g6 lists affected ranges: Maven net.sf.mpxj:mpxj >=8.3.5 =8.3.5 =8.3.5 =8.3.5 =8.3.5 =8.3.5 =13.0.0 <13.5.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j945-c44v-97g6 lists affected ranges: Maven net.sf.mpxj:mpxj >=8.3.5 =8.3.5 =8.3.5 =8.3.5 =8.3.5 =8.3.5 =13.0.0 <13.5.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:A/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-49771: 0.48% estimated exploitation activity in the next 30 days; percentile 41.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The patch for the historical vulnerability CVE-2020-35460 in MPXJ is incomplete as there is still a possibility that a malicious path could be constructed which would not be picked up by the original fix and allow files to be written to arbitrary locations. Patches The issue is addressed in MPXJ version 13.5.1 Workarounds Do not pass zip files to MPXJ. References N/A Credits Issue report and patch provided by yyjLF and sprinkle
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-j945-c44v-97g6
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-j945-c44v-97g6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-49771 Advisory: MPXJ has a Potential Path Traversal Vulnerability IDs: CVE-2024-49771, GHSA-j945-c44v-97g6 Record: https://patchnext.com/advisories/cve-2024-49771 (revision 3, source checked 26 Oct 2026, 13:25 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mpxj.net 13.5.1; net.sf.mpxj 13.5.1; mpxj 13.5.1; net.sf.mpxj:mpxj 13.5.1; net.sf.mpxj-for-vb 13.5.1; mpxj 13.5.1; net.sf.mpxj-for-csharp 13.5.1. A vendor fix does not mean a deployment is fixed. ## Affected components - NuGet mpxj.net: affected >= 13.0.0, < 13.5.1; fixed in 13.5.1 - NuGet net.sf.mpxj: affected >= 8.3.5, < 13.5.1; fixed in 13.5.1 - RubyGems mpxj: affected >= 8.3.5, < 13.5.1; fixed in 13.5.1 - Maven net.sf.mpxj:mpxj: affected >= 8.3.5, < 13.5.1; fixed in 13.5.1 - NuGet net.sf.mpxj-for-vb: affected >= 8.3.5, < 13.5.1; fixed in 13.5.1 - PyPI mpxj: affected >= 8.3.5, < 13.5.1; fixed in 13.5.1 - NuGet net.sf.mpxj-for-csharp: affected >= 8.3.5, < 13.5.1; fixed in 13.5.1 ## Suggested inspection (read-only) - NuGet mpxj.net: check the installed version with your package manager. - NuGet net.sf.mpxj: check the installed version with your package manager. - RubyGems mpxj: check the installed version with your package manager. - Maven net.sf.mpxj:mpxj: check the installed version with your package manager. - NuGet net.sf.mpxj-for-vb: check the installed version with your package manager. - `python -m pip show mpxj`: prints the installed version. Run with the environment that serves production active. - NuGet net.sf.mpxj-for-csharp: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mpxj.net, net.sf.mpxj, mpxj, net.sf.mpxj:mpxj, net.sf.mpxj-for-vb, net.sf.mpxj-for-csharp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-j945-c44v-97g6 (OSV record GHSA-j945-c44v-97g6 lists affected ranges: Maven net.sf.mpxj:mpxj >=8.3.5 =8.3.5 =8.3.5 =8.3.5 =8.3.5 =8.3.5 =13.0.0 <13.5.1 (fixed)) - Verified: https://github.com/advisories/GHSA-j945-c44v-97g6 (GitHub-reviewed advisory GHSA-j945-c44v-97g6 lists affected ranges: Maven net.sf.mpxj:mpxj >=8.3.5 =8.3.5 =8.3.5 =8.3.5 =8.3.5 =8.3.5 =13.0.0 <13.5.1) Commands are suggestions: review each one before running it.
Loading voting…