Werkzeug possible resource exhaustion when parsing file data in forms
CVE-2024-49767GHSA-q34m-jh98-gwm2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (quart 0.20.0; werkzeug 3.0.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-q34m-jh98-gwm2 lists affected ranges: PyPI werkzeug >=2.0.0rc1 =0 <0.20.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q34m-jh98-gwm2 lists affected ranges: PyPI quart >=0 =2.0.0rc1 <=3.0.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-49767: 1.09% estimated exploitation activity in the next 30 days; percentile 65.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Applications using Werkzeug to parse multipart/form-data requests are vulnerable to resource exhaustion. A specially crafted form body can bypass the Request.maxformmemorysize setting. The Request.maxcontentlength setting, as well as resource limits provided by deployment software and platforms, are also available to limit the resources used during a request. This vulnerability does not affect those settings. All three types of limits should be considered and set appropriately when deploying an application.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-q34m-jh98-gwm2
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-q34m-jh98-gwm2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-49767 Advisory: Werkzeug possible resource exhaustion when parsing file data in forms IDs: CVE-2024-49767, GHSA-q34m-jh98-gwm2 Record: https://patchnext.com/advisories/cve-2024-49767 (revision 3, source checked 26 Oct 2026, 13:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: quart 0.20.0; werkzeug 3.0.6. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI quart: affected < 0.20.0; fixed in 0.20.0 - PyPI werkzeug: affected >= 2.0.0rc1, <= 3.0.5; fixed in 3.0.6 ## Suggested inspection (read-only) - `python -m pip show quart`: prints the installed version. Run with the environment that serves production active. - `python -m pip show werkzeug`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on quart, werkzeug. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-q34m-jh98-gwm2 (OSV record GHSA-q34m-jh98-gwm2 lists affected ranges: PyPI werkzeug >=2.0.0rc1 =0 <0.20.0 (fixed)) - Verified: https://github.com/advisories/GHSA-q34m-jh98-gwm2 (GitHub-reviewed advisory GHSA-q34m-jh98-gwm2 lists affected ranges: PyPI quart >=0 =2.0.0rc1 <=3.0.5) Commands are suggestions: review each one before running it.
Loading voting…