The Snowflake Connector for Python stores sensitive data in logs
CVE-2024-49750GHSA-5vvg-pvhp-hv2m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (snowflake-connector-python 3.12.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI snowflake-connector-python
- Affected
- < 3.12.3
- Fixed in
- 3.12.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5vvg-pvhp-hv2m lists affected ranges: PyPI snowflake-connector-python >=0 <3.12.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5vvg-pvhp-hv2m lists affected ranges: PyPI snowflake-connector-python >=0 <3.12.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.5 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2024-49750: 0.20% estimated exploitation activity in the next 30 days; percentile 10.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Issue Snowflake recently learned about and remediated a set of vulnerabilities in the Snowflake Connector for Python. Under specific conditions, certain users credentials (or portions of those credentials) were logged locally by the Connector to the users own systems. The credentials were not logged by Snowflake. These vulnerabilities affect versions up to and including 3.12.2. Snowflake fixed the issue in version 3.12.3. Vulnerability Details When the logging level was set by the user to DEBUG, the Connector could have logged Duo passcodes (when specified via the “passcode” parameter) and Azure SAS tokens. Additionally, the SecretDetector logging formatter, if enabled, contained bugs which caused it to not fully redact JWT tokens and certain private key formats. Solution Snowflake released version 3.12.3 of the Snowflake Connector for Python, which fixes these issues. We recommend users upgrade to version 3.12.3 and review their logs for any potentially sensitive information that…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-5vvg-pvhp-hv2m
- Revision 1 · created ·
Published from osv record GHSA-5vvg-pvhp-hv2m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-49750 Advisory: The Snowflake Connector for Python stores sensitive data in logs IDs: CVE-2024-49750, GHSA-5vvg-pvhp-hv2m Record: https://patchnext.com/advisories/cve-2024-49750 (revision 2, source checked 26 Oct 2026, 13:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: snowflake-connector-python 3.12.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI snowflake-connector-python: affected < 3.12.3; fixed in 3.12.3 ## Suggested inspection (read-only) - `python -m pip show snowflake-connector-python`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on snowflake-connector-python. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5vvg-pvhp-hv2m (OSV record GHSA-5vvg-pvhp-hv2m lists affected ranges: PyPI snowflake-connector-python >=0 <3.12.3 (fixed)) - Verified: https://github.com/advisories/GHSA-5vvg-pvhp-hv2m (GitHub-reviewed advisory GHSA-5vvg-pvhp-hv2m lists affected ranges: PyPI snowflake-connector-python >=0 <3.12.3) Commands are suggestions: review each one before running it.
Loading voting…