Skip to content

← Actionable
High, CVSS 7.7amended

Remote Code Execution on click of Link in markdown preview

CVE-2024-49362GHSA-hff8-hjwv-j9q7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (joplin 3.1.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm joplin

    Affected
    >= 3.0.0, <= 3.0.0
    Fixed in
    3.1.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.7 · CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:L
EPSS
  • CVE-2024-49362: 1.06% estimated exploitation activity in the next 30 days; percentile 64.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary There is a vulnerability in Joplin-desktop that leads to remote code execution (RCE) when a user clicks on an <a link within untrusted notes. The issue arises due to insufficient sanitization of <a tag attributes introduced by the Mermaid. This vulnerability allows the execution of untrusted HTML content within the Electron window, which has full access to Node.js APIs, enabling arbitrary shell command execution. Details In the markdown preview iframe, Joplin only opens <a links internally within the same Electron window if they contain the data-from-md attribute. While Joplin successfully sanitizes the data-from-md attribute in user-embedded <a links from the .md file to prevent the execution of untrusted HTML content, it fails to sanitize the data-from-md attributes of <a tags introduced by Mermaid (e.g., the code snippet shown below). Since Mermaid allows the rendering of certain scriptless HTML elements, an attacker can embed <a tags with data-from-md attributes, which…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-hff8-hjwv-j9q7

  2. Revision 1 · created ·

    Published from osv record GHSA-hff8-hjwv-j9q7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-49362

Advisory: Remote Code Execution on click of Link in markdown preview
IDs: CVE-2024-49362, GHSA-hff8-hjwv-j9q7
Record: https://patchnext.com/advisories/cve-2024-49362 (revision 2, source checked 26 Oct 2026, 12:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: joplin 3.1.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm joplin: affected >= 3.0.0, <= 3.0.0; fixed in 3.1.0

## Suggested inspection (read-only)
- `npm ls joplin --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on joplin.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hff8-hjwv-j9q7 (OSV record GHSA-hff8-hjwv-j9q7 lists affected ranges: npm joplin >=3.0.0 <3.1.0 (fixed))
- Verified: https://github.com/advisories/GHSA-hff8-hjwv-j9q7 (GitHub-reviewed advisory GHSA-hff8-hjwv-j9q7 lists affected ranges: npm joplin >=3.0.0 <=3.0.0)

Commands are suggestions: review each one before running it.

Loading voting…