Skip to content

← Actionable
High, CVSS 8.8

Querydsl vulnerable to HQL injection through orderBy

CVE-2024-49203GHSA-6q3q-6v5j-h6vg

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven com.querydsl:querydsl-jpa

    Affected
    <= 5.1.0
    Fixed in
    no fixed version recorded
  • Maven io.github.openfeign.querydsl:querydsl-apt

    Affected
    >= 6.0.0.M1, < 6.10.1< 5.6.1
    Fixed in
    5.6.1, 6.10.1
  • Maven io.github.openfeign.querydsl:querydsl-jpa

    Affected
    >= 6.0.0.M1, < 6.10.1< 5.6.1
    Fixed in
    5.6.1, 6.10.1
  • Maven com.querydsl:querydsl-apt

    Affected
    <= 5.1.0
    Fixed in
    no fixed version recorded

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-6q3q-6v5j-h6vg lists affected ranges: Maven io.github.openfeign.querydsl:querydsl-jpa >=6.0.0.M1 =0 =6.0.0.M1 =0 =0 =0 <=5.1.0

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-49203: 0.41% estimated exploitation activity in the next 30 days; percentile 35.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The order by method enables injecting HQL queries. This may cause blind HQL injection, which could lead to leakage of sensitive information, and potentially also Denial Of Service. This vulnerability is present since the original querydsl repository(https://github.com/querydsl/querydsl) where it was assigned preliminary CVE identifier CVE-2024-49203. Details Vulnerable code may look as follows: Where vulnerability is either caused by or the method itself, based on where the security checks are expected. PoC Full POC code is available in repository: https://github.com/CSIRTTrizna/CVE-2024-49203/ When we take a look at source code shown in Details section the functionality is as follows: 1) Create JPAQuery object instance: 2) Create OrderSpecifier object instance: Where orderBy variable is user provided input. 3) order and run the query When user goes to URL The generated query will look something like this: Environment Library versions used in proof of concept to reproduce the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-6q3q-6v5j-h6vg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-49203

Advisory: Querydsl vulnerable to HQL injection through orderBy
IDs: CVE-2024-49203, GHSA-6q3q-6v5j-h6vg
Record: https://patchnext.com/advisories/cve-2024-49203 (revision 1, source checked 26 Oct 2026, 16:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: io.github.openfeign.querydsl:querydsl-apt 6.10.1, 5.6.1; io.github.openfeign.querydsl:querydsl-jpa 6.10.1, 5.6.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven com.querydsl:querydsl-jpa: affected <= 5.1.0
- Maven io.github.openfeign.querydsl:querydsl-apt: affected >= 6.0.0.M1, < 6.10.1; < 5.6.1; fixed in 5.6.1, 6.10.1
- Maven io.github.openfeign.querydsl:querydsl-jpa: affected >= 6.0.0.M1, < 6.10.1; < 5.6.1; fixed in 5.6.1, 6.10.1
- Maven com.querydsl:querydsl-apt: affected <= 5.1.0

## Suggested inspection (read-only)
- Maven com.querydsl:querydsl-jpa: check the installed version with your package manager.
- Maven io.github.openfeign.querydsl:querydsl-apt: check the installed version with your package manager.
- Maven io.github.openfeign.querydsl:querydsl-jpa: check the installed version with your package manager.
- Maven com.querydsl:querydsl-apt: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on com.querydsl:querydsl-jpa, io.github.openfeign.querydsl:querydsl-apt, io.github.openfeign.querydsl:querydsl-jpa, com.querydsl:querydsl-apt.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6q3q-6v5j-h6vg (GitHub-reviewed advisory GHSA-6q3q-6v5j-h6vg lists affected ranges: Maven io.github.openfeign.querydsl:querydsl-jpa >=6.0.0.M1 =0 =6.0.0.M1 =0 =0 =0 <=5.1.0)

Commands are suggestions: review each one before running it.

Loading voting…