Skip to content

← Actionable
High, CVSS 8.1amended

TorchGeo Remote Code Execution Vulnerability

CVE-2024-49048GHSA-ghq9-vc6f-8qjf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (torchgeo 0.6.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI torchgeo

    Affected
    >= 0.4, <= 0.6.0
    Fixed in
    0.6.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2024-49048: 1.24% estimated exploitation activity in the next 30 days; percentile 69.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact TorchGeo 0.4–0.6.0 used an eval statement in its model weight API that could allow an unauthenticated, remote attacker to execute arbitrary commands. All platforms that expose torchgeo.models.getweight() or torchgeo.trainers as an external API could be affected. Patches The eval statement was replaced with a fixed enum lookup, preventing arbitrary code injection. All users are encouraged to upgrade to TorchGeo 0.6.1 or newer. Workarounds In unpatched versions, input validation and sanitization can be used to avoid this vulnerability. References Bug history Introduced: https://github.com/torchgeo/torchgeo/pull/917 Patched: https://github.com/torchgeo/torchgeo/pull/2323 Released: v0.6.1

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-ghq9-vc6f-8qjf

  2. Revision 1 · created ·

    Published from osv record GHSA-ghq9-vc6f-8qjf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-49048

Advisory: TorchGeo Remote Code Execution Vulnerability
IDs: CVE-2024-49048, GHSA-ghq9-vc6f-8qjf
Record: https://patchnext.com/advisories/cve-2024-49048 (revision 2, source checked 26 Oct 2026, 13:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: torchgeo 0.6.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI torchgeo: affected >= 0.4, <= 0.6.0; fixed in 0.6.1

## Suggested inspection (read-only)
- `python -m pip show torchgeo`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on torchgeo.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-ghq9-vc6f-8qjf (OSV record GHSA-ghq9-vc6f-8qjf lists affected ranges: PyPI torchgeo >=0.4 <0.6.1 (fixed))
- Verified: https://github.com/advisories/GHSA-ghq9-vc6f-8qjf (GitHub-reviewed advisory GHSA-ghq9-vc6f-8qjf lists affected ranges: PyPI torchgeo >=0.4 <=0.6.0)

Commands are suggestions: review each one before running it.

Loading voting…