Skip to content

← Actionable
Low, CVSS 2.7amended

Elliptic's verify function omits uniqueness validation

CVE-2024-48949GHSA-434g-2637-qmqr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (elliptic 6.5.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm elliptic

    Affected
    < 6.5.6
    Fixed in
    6.5.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:U · score source
EPSS
  • CVE-2024-48949: 0.50% estimated exploitation activity in the next 30 days; percentile 42.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The Elliptic package 6.5.5 for Node.js for EDDSA implementation does not perform the required check if the signature proof(s) is within the bounds of the order n of the base point of the elliptic curve, leading to signature malleability. Namely, the verify function in lib/elliptic/eddsa/index.js omits sig.S().gte(sig.eddsa.curve.n) || sig.S().isNeg() validation. This vulnerability could have a security-relevant impact if an application relies on the uniqueness of a signature.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-434g-2637-qmqr

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-434g-2637-qmqr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-48949

Advisory: Elliptic's verify function omits uniqueness validation
IDs: CVE-2024-48949, GHSA-434g-2637-qmqr
Record: https://patchnext.com/advisories/cve-2024-48949 (revision 3, source checked 26 Oct 2026, 12:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: elliptic 6.5.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm elliptic: affected < 6.5.6; fixed in 6.5.6

## Suggested inspection (read-only)
- `npm ls elliptic --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on elliptic.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-434g-2637-qmqr (OSV record GHSA-434g-2637-qmqr lists affected ranges: npm elliptic >=0 <6.5.6 (fixed))
- Verified: https://github.com/advisories/GHSA-434g-2637-qmqr (GitHub-reviewed advisory GHSA-434g-2637-qmqr lists affected ranges: npm elliptic >=0 <6.5.6)

Commands are suggestions: review each one before running it.

Loading voting…